Jump to content
Macro Express Forums
Alwarogam

Delay problem when running a Macro

Recommended Posts

Hello all,

 

I am having some issues running macros.

 

Imagine a Macro as simple as this:

 

<TEXT TYPE Action="0" Text="A"/>

Activation: Hotkey K

 

When I run the macro pressing K should write A in notepad. The problems comes becouse there is a dalay of about 1 second after i release the K key to the macro to writte the A letter.

 

I am running a Windows 10. I have tested in 2 other computers and it Works just fine without any delay at all.

 

I have been working with Macro Express for about 10 years and never had this issue before.

 

Thanks for your help.

 

 

Share this post


Link to post
Share on other sites

I don't know. Maybe try again in Windows Safe Mode. If it's instant in safe mode then something running is causing it. Also I'd scan for malware. There are some that have keystroke loggers that can cause this behavior.

 

Also start a support ticked with ISS. They're usually pretty responsive.

Share this post


Link to post
Share on other sites

In your simple macro, write a message (with time stamping) to the ME error log as the first line of the macro.

Log Message to Default Error Log

Then write another message immediately before and immediately after the Text Type command.

Get a clock with second hand running on the screen and initiate the macro exactly on a five or ten second mark or whatever.

Then review the log and see if it tells you anything useful as to where the delay is occurring.

 

In ME Options - Preferences check your settings for Delays. Compare between the computer(s) where it works right and the one where it doesn't.

Share this post


Link to post
Share on other sites

In the help menu there's also a menu item "Online Support"

Share this post


Link to post
Share on other sites

What happened when you tried it in Safe Mode?

Share this post


Link to post
Share on other sites

That is strange. You might have simply had some malware that was running but unable to hook itself in for reboot.

Share this post


Link to post
Share on other sites

The May 2016 update of Windows Defender running on Windows 10 is causing a delay running a macro. The macro activation occurs then there is a delay of 1 to 6 seconds before the macro commands run. We have reported the problem to Microsoft. There are other reports on the Microsoft Forums about this update of Windows Defender causing high CPU utilization.

 

Here are some ways to work around this issue:

  • This issue does not occur if you are using a different security software program.
  • We discovered two different versions of Windows Defender running on our Windows 10 systems. The delay for one of these goes away if Windows Defender's "Real Time Protection" is turned off. This did not correct the problem with the other version of Windows Defender.
  • Create a separate macro containing a Message Box macro command. Run it and leave it running with the Message Box displayed. Your other macros may run quicker. We have had mixed success with this. One customer reports that this works them. We found it worked on one of our systems for a time but later stopped working.
You may contact the Insight Software Solutions Support Team for an updated status and other possible solutions for this issue.

Share this post


Link to post
Share on other sites

I wonder if one can exclude the MEP executable from scrutiny as with other security software and if that would help.

  • Like 1

Share this post


Link to post
Share on other sites

Here is another work-around. Thanks to Cory for the suggestion.

The delay running a macro can be eliminated by adding Macro Express Pro's macexp.exe to Windows Defender exclusion list.

  • Open Windows 10 Settings dialog
  • Click on Update & Security
  • Click on Windows Defender in the column on the left
  • Scroll down until you see the Exclusions header
  • Click on Add an Exclusion
  • Under the Files and folders header click on Exclude a file
  • Navigate to where your Macro Express Pro program files are located. By default this is c:\Program Files(x86)\Macro Express Pro.
  • Click to highlight macexp.exe
  • Click the Exclude this file button
  • Close the Settings dialog

Share this post


Link to post
Share on other sites

I didn run in Save Mode and worked fine then i restarted in normal mode and worked fine again !!!!!

I tried this and macros ran fast while in Safe Mode but the delay returned when I booted into normal mode.

 

Adding macexp.exe to the Windows Defender Exclusion list worked for me.

Share this post


Link to post
Share on other sites

Oh cool, there is an exclusion list. Thanks Samrae!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×