Jump to content
Macro Express Forums

Recommended Posts

Have I overlooked a setting that will remove the Sidebar please?

I appreciate it's only a few keystrokes to toggle it off/on, but I very rarely need it and I use the extra space it takes.

If there is no setting, how about a hack?

(I tried a simple macro activated by MX Explorer opening, but found it unreliable.)

Terry, East Grinstead, UK

Share this post


Link to post
Share on other sites

I have kept the sidebar hidden for so long that I forgot it existed! Like you, I find it takes up too much UI real estate. The only thing I might use it for is a shortcut for creating a new macro, but I already have a hotkey macro that creates a new macro.

 

What I did years ago was choose Options > View > Sidebar. The Sidebar hasn't appeared since.

 

 

Share this post


Link to post
Share on other sites

So your sidebar doesn't appear automatically every time you start MX Explorer?

That seems to imply there's a 'Save settings' option somewhere that I've missed. I'll take another look when back at my PC tomorrow.

Terry, UK

Share this post


Link to post
Share on other sites

The setting in Options > View has been a permanent solution. I checked Options > Preferences and found no settings for the sidebar.

Odd that the Sidebar setting doesn't stick for you. Hope you sort it out!

Share this post


Link to post
Share on other sites

In a more careful check of Preferences I found this setting which appeared to be what I'd missed.

MXPro-SaveSettings.jpg.421ac7a4b69981f150ba27f00b1f6063.jpg

But using it caused further problems as follows.

I ensured that the Sidebar was not displayed. Then I enabled Preferences > General > Misc > 'Save settings as defaults for all users' and clicked Apply.

But as soon as I clicked OK, my main macro file FULL-2016.mex was suddenly closed and this empty macex.mex file appeared in its place.

MXPro-SaveSettings-2.jpg.142166aaf9a48d1af1913d3d18a8e342.jpg

If I then re-opened FULL.mex, the Sidebar was back and I found that the above setting was again now disabled.

Worse, I'm now unable to close that macex.mex file.

Terry, East Grinstead, UK

 

MXPro-CannotCloseFile.jpg

Share this post


Link to post
Share on other sites

Hi Terry,

I wonder if something got corrupted in your installation.

Make sure your macro file or files have been backed up. Uninstall Macro Express Pro, reinstall it, and reload your macro files.

Share this post


Link to post
Share on other sites

Thanks acantor. I think the registry had somehow become corrupted. After deleting the main ISS section and rebooting etc, things are now OK.

Appreciated your help.

Terry, East Grinstead, UK 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×