Jump to content
Macro Express Forums
FTI

Text Type dropping characters in Postbox

Recommended Posts

I updated my Postbox email client to version 5.0.22 two days ago...then executing Text Type macros from my old Macro Express 3.9a dropped characters when creating new emails in Postbox.

So I updated Macro Express to the current 3.11.1.1, but it still drops characters--always the same characters for any given macro--in Postbox.

For instance "screenshot" is always "creenshot".

Is there a setting, or other, in Macro Express which might have bearing on this problem?

 

Share this post


Link to post
Share on other sites

I have seen this behavior on rare occasions, but don't recall that I ever really figured it out.
A few things to try:
1) Set keystroke speed to a reasonable value -- I generally use 30ms, but that's just an arbitrary value.
2) If you are using the Text Type option that pastes from the clipboard, don't use it.
3) Try typing a few blanks, then type the same number of backspaces to get back to the beginning of the field, then type the real data.  That has worked for me sometimes.  I know, it's sort of a Mickey Mouse fix, but if it works ... ^_^

Share this post


Link to post
Share on other sites

Thanks for ideas....tried them all; no change. 

However, if I disabled Use high speed timer in millisecond delays, the problem improved for characters that were dropped in the middle of a word or group of lines. For instance:

"ManagePLUS" was "anageLUS" but after disabling the high speed timer is "anagePLUS"  (The "P" is now present.)

This was not a problem in the old Postbox version, and is not a problem in other applications. Likely due to Postbox using a significantly cross-platform code base, which somehow is not fully compatible with the keystroke sending facilities of Windows.

...if you have any other ideas, I'd be glad to hear them. Thank again.

 

Share this post


Link to post
Share on other sites

Just as an experiment, try "Keystroke Speed: 1000 Milliseconds".  It will be excruciatingly slow, but if it works then you know timing is the issue and you can experiment with other speeds.

Or maybe do the opposite of my second suggestion: use the Text Type option that pastes from clipboard.  Though that option has always been troublesome for me.

Share this post


Link to post
Share on other sites

Interestingly, I had already tried a keystroke speed of 3000 ms.!   Didn't help...but thanks for trying to help me out.

Share this post


Link to post
Share on other sites

This approach solved a dropped character problem when I was creating ME macros for an Java application:

 

In the Control Panel, go to Keyboard Properties, and reduce the repeat rate. Setting the value to 25% or 30% was enough to prevent characters from dropping when I sent input via Text Type.

Share this post


Link to post
Share on other sites

Good thinking!  Though I can't quite "logic" out why that works.:huh: I would have guessed Repeat Delay would make the difference, rather than Rate. 

Now that you have me thinking about it, I lengthened my Repeat Delay, because maybe the short delay accounts for some of the the double-character errors I have been making lately with my typing.  I was blaming sluggish fingers or sticking keys, and it never occurred to me to blame the keyboard settings.  (Sorry, this has nothing to do with ME macros, I'm just happy to get rid offff thoose exxtra chaaraactters I have beenn typping.)

Share this post


Link to post
Share on other sites

Thanks acantor; makes sense as something to try! However, even at the slowest repeat rate it didn't have any on the problem.

I'm settling on the idea that this is a problem with how Postbox works with the Windows API.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×