Jump to content
Macro Express Forums
MakaPakaTobyHannah

Gmail / Googlemail settings

Recommended Posts

I have been unable to configure the email settings in preferences to allow me to send an outgoing email via my googlemail account.

I applied the following settings:

Host: smtp.gmail.com
Port: 465

The system requires authentication: check.

(Entered my username and password).

The macro executes, takes a few seconds, then returns:

"The message could not be sent. ’Connection Closed Gracefully.’"

I did try Port 25, though I don’t believe that’s the correct setting.

I noticed, in the gmail SMTP instructions:

Gmail SMTP TLS/SSL required: yes.

I see no option for specifying anything like this in the email settings.

I have always wanted to use the send email feature, but have never been able to do so. Perhaps it isn’t possible with gmail?

Any advice, anyone? I couldn’t find a "gmail" specific discussion here in the forum. Many thanks!

Share this post


Link to post
Share on other sites

I don't know about your Gmail problem but I had a client whom I wanted to set up to send notifications but their IT people were reticent to share their server's settings and I didn't want them to have my credentials. I set them up with SMTP-Pulse. One can send up to 12k messages a month for free. I have not tried them with MEP. 

Also make sure you don't have a firewall issue by disabling your firewall or other security software for testing. 

Share this post


Link to post
Share on other sites

I tried your settings with Macro Express version 3 and got the same error you did. 

I changed the port to 25 and got the "success" message from two send commands, and the ME email log showed success, but neither recipient got the mail, and my gmail account does not show the messages in its Sent folder. 

Sorry, no help from me.  But please post again if you figure it out because it would be handy to have it working. 

Share this post


Link to post
Share on other sites

Thanks for the feedback so far. I am trying SMTP-Pulse at the moment; so far, no success...

My aim is a simple one: I have one particular macro that works with a 16-bit DOS program (yes!), running in DOSBox, that processes any number of files in succession, but depends on keyboard input being piped into the program. For this reason, when this macro runs, my computer is captive; I can’t work on anything else, as the next keyboard input string then would not properly pipe into the DOS program when the macro executes the next iteration. So I tend to go off and do something else (coffee break - whatever). I would like ME to notify me by email when the process is completed.

It’s cute, I know... but still, I’d like to get this to work.

Thanks to Cory (as always) and rberg. If I find a solution, I’ll post again. Or if anybody else knows something, I’d love to find out. Cheers.

Share this post


Link to post
Share on other sites

Here are a couple links I found through Google.  I tinkered a bit but didn’t get it to work yet.  Basically a script file and a batch file to execute the script.  If you can get it to work then you can run (launch) the batch file from Macro Express.

Script “testgmail.ps1”:

    $EmailFrom = “myemailname@gmail.com”
    $EmailTo = “addressee@yahoo.com”
    $Subject = “test subject line”
    $Body = “test text”
    $SMTPServer = “smtp.gmail.com”
    $SMTPClient = New-Object Net.Mail.SmtpClient($SmtpServer, 587)
    $SMTPClient.EnableSsl = $true
    $SMTPClient.Credentials = New-Object System.Net.NetworkCredential(“myemailname”, “myPasswrd”);

    $SMTPClient.Send($EmailFrom, $EmailTo, $Subject, $Body)

pause

Batch file:
cd\windows\system32\WindowsPowerShell\v1.0
powershell c:\temp\testgmail.ps1
pause

https://superuser.com/questions/80255/send-email-via-gmail-from-command-prompt

https://www.howtogeek.com/120011/stupid-geek-tricks-how-to-send-email-from-the-command-line-in-windows-without-extra-software/

Edit: edited this post to give the script file name the extension "ps1" instead of "txt".

 

Share this post


Link to post
Share on other sites
2 hours ago, michaelkenward said:

GMail accepts Port 25 for SMTP only if you are sending to a GMail address.

 

Are you saying you have it working with Macro Express?  What settings?

Share this post


Link to post
Share on other sites

If you email to a Gmail you could set up a forwarder to any address. 

I'm using smtp-pulse on my MEP and it works fine. Just tested it now. Here are my settings. I'm guessing your problem is that you need to add an exclusion to your firewall for 2525.

Share this post


Link to post
Share on other sites

Have you checked your spam folders?

Share this post


Link to post
Share on other sites

Yes, nothing in Spam. I opened an smtp-pulse account, no luck yet, Cory, but will try to work this out. If it works for you, it should work for me. This would be quite cool... thanks for staying engaged! I’ll update the thread, as (and if) i make progress.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×