Jump to content
Macro Express Forums

mdoverman

Members
  • Content Count

    16
  • Joined

  • Last visited

Everything posted by mdoverman

  1. To call a Macro Express macro from Dragon the command is ShellExecute, not Shell. If calling from Knowbrainer, the Shell command is correct. Ex: Sub Main ShellExecute "c:\Program Files (x86)\Macro Express Pro 6\meproc.exe /AResults Lipid Panel" End Sub
  2. Unfortunately, I don't have any simple macros showing this. In the attached files, the Aspirin_Yes macro would be one I would run. The first thing it does is run the Aprima Variables macro. That macro checks my registry for the screen resolution key I placed in the registry and runs the appropriate macro for that PC screen resolution. That macro then sets the location of various buttons, tabs, etc in my EMR (unfortunately this EMR is not totally windows compliant so I have to do a lot of mouse clicks). Once that macro runs, the Aspirin_Yes macro resumes. 3240x2160.mex Aprima Variables.mex
  3. Multiple choice menu is in the Dialogs section. The variable set string is in the variable section. Very basic example attached. Audio.mex
  4. I'm not a programmer either, but having used Macro Express for a number of years I can manage fairly well. You should be able to use a multiple choice menu or Variable set string in your macro to ask you to select what genre you want which will put your choice in a variable that can be used later in your macro to put the file in the correct folder.
  5. I run the same macros on computers with different screen sizes. I set a registry key with information for a particular screen or with a computer name. I then have Macro Express read the registry key into a variable and then I can control which parts or which macros will run on each machine.
  6. I discovered the problem was because the upgrade process from ME Pro 4 to 6 did not update the icon location for those macros that I had used a custom icon from the ME Pro Icons folder. When I deleted the ME Pro 4 folders, those macros had no assigned icon. When I corrected all the macros that were involved, the menu builder began working correctly.
  7. I have upgraded from ME Pro 4 to 6 on a Windows 10 machine and a Windows 7 machine. On the Windows 7 machine I uninstalled ME Pro 4 but not yet on the Windows 10 machine. When I try to edit or build a new popup menu I have no problem on the Windows 10 machine but on the Windows 7, the only macros that are available in the list of macros of the menu builder are "Run Macro Express Editor" and "Terminate Macro Express". I have tried uninstalling/reinstalling to no avail. Any Ideas?
  8. Terry, this looked like an interesting macro I could use to learn more about arrays and also to possibly use to build other macros but I keep getting an error on Line 2 of an undefined variable or the variable is the wrong type. Thanks, Mark
  9. I use separate macros with mouse coordinate variables specific to a particular screen resolution. I then have my macros first check the screen resolution (I have a registry setting where I record the screen resolution for the particular PC) and run the macro containing the variables for the mouse locations for that particular screen resolution. My mouse position commands are then setup similar to Mouse Move: %Search_x%, %Search_y% Relative to screen. MOverman
  10. Using the Alt key doesn't seem to make a difference and whether or not the underlining of the accelerator key is there or not seems totally random. I can live with it. Thanks for all the responses.
  11. Another gremlin must have been at work, now the accelerator keys are showing up underlined as they should. Go figure. Mark
  12. I have a number of macros that incorporate multiple choice menus with accelerator keys assigned to the menu choices. None of them show the accelerated keys underlined although the accelerator keys do function normally. This is on a Surface Pro 3 running Windows 8.1 64 bit. It does not matter whether I have preselected a menu choice or not. The menu options are set for single choice. I don't recall having this same issue on other PCs running Windows 7. Any help appreciated. Mark
  13. Thanks, I'll do that and put the shortcut in the startup folder.
  14. I am running Macro Express Pro in Windows 8.1 and need it to be run as an administrator in order for the lock keyboard function to work. I now have MExP starting with Windows. Is there a command line parameter or some other way to force it to run as administrator on startup? Thanks, Mark
×
×
  • Create New...