Jump to content
Macro Express Forums

fewmoredetails

Members
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About fewmoredetails

  • Rank
    Newbie
  1. Wow! Samrae you rock! Running ME as Admin solved the issue instantly. Appreciate your help.
  2. Wow! Samrae you rock! Running ME as Admin solved the issue instantly. Appreciate your help.
  3. Hi everybody, I have been using ME in Window7 for a trading program for few years and it worked fine. Last week, I upgraded from Window7 to Windows 10 and ME is not working properly. My script launches a trading program and once it appears in Windows, activates it, and reposition to top left corner. <PROGRAM LAUNCH Path="C:\\NHTrader\\WooriTrader.exe" Mode="\x00" Default_Path="TRUE" Wait="5" Get_Console="FALSE"/> <DELAY Flags="\x01" Time="2"/> <WINDOW ACTIVATE Title="NH트레이더" Exact_Match="TRUE" Wildcards="FALSE" _IGNORE="0x0006"/> <SET WINDOW ORDER Window="\x01" Title="NH트레이더" Partial="TRUE" Wildcards="FALSE" Action="\x00" _IGNORE="0x0006"/> <TEXT TYPE Action="0" Text="1234"/> <VARIABLE SET STRING Option="\x05" Destination="%T[1]%"/> <WINDOW REPOSITION Option="\x01" Title="%T[1]%" Partial="FALSE" Wildcards="FALSE" Method="\x02" Left="0" Top="0" Monitor="0"/> <MESSAGEBOX Caption="rdrd%T[1]%trdr" Message="rdrd%T[1]%rdrd" Icon="1"/> In windows 10, it seems that ME does not recognize my trading program as a valid window. 1. If WINDOW REPOSITION command fails to recognize the window with Title="NH트레이더", it should fail, but it never does. In message box, its text is properlly captured. 2. Even though WINDOW REPOSITION command recognizes the window, reposition command itself does not work. Nothing happens to the target window. 3. I realized that mouse Locator tools does not work when the cursor is over the window of target program. Value in Pixel color keeps changing as I move the cursor on the target window, but value in position does not change. 4. Instead of WINDOW REPOSITION command, I tried TEXT TYPE command too, but it doesn't work either. Any one experiencing the same in Window10? Appreciate your valuable feedback in advance.
×
×
  • Create New...