Jump to content
Macro Express Forums

Search the Community

Showing results for tags 'Text input on locked workstat'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News and Information
    • Guidelines for all Forums
  • Community Forums
    • Macro Express and Macro Express Pro
    • Macro Express 3.x
    • Macro Express 3.x Third Party Tools
  • Private Forums
  • Forum Archives

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hi Guys, Just signed up, hoping someone would be able to help me out! I'm trying to use macro express to shutdown a program, launch it again, enter in a username-password and hit enter. My problem is that even though the program shutdowns and restarts- none of the text entries (username and password) work. When I log back in to the workstation in morning the program is open and waiting for the username and password to be entered. The macro works perfectly when I test run it while logged into the system. Below is the macro. Any help would be appreciated. Thanks AtinK <IF PROGRAM Option="\x01" Program="XYZ"/> <TERMINATE PROCESS Window="FALSE" Name="XYZ" Partial="TRUE" Wildcards="TRUE" Timeout="1000"/> <END IF/> <DELAY Flags="\x01" Time="5"/> <LAUNCH PROGRAM AND ACTIVATE WINDOW Title="XYZ" Exact_Match="FALSE" Wildcards="FALSE" Path="C:\\Program Files\\XYZ.exe" Mode="\x00" Default_Path="TRUE" Wait="1" Wait_For_Program="12"/> <IF NOT PROGRAM Option="\x00" Program="XYZ.EXE"/> <WINDOW ACTIVATE Title="XYZ" Exact_Match="FALSE" Wildcards="FALSE" _IGNORE="0x0006"/> <END IF/> <WINDOW ACTIVATE Title="XYZ" Exact_Match="FALSE" Wildcards="FALSE"/> <DELAY Flags="\x01" Time="3"/> <TEXT TYPE Action="0" Control="%C[1]%" Text="username" _PROMPT="0x0004"/> <DELAY Flags="\x01" Time="2"/> <TEXT TYPE Action="0" Text="<TAB>"/> <DELAY Flags="\x01" Time="2"/> <TEXT TYPE Action="0" Text="password"/> <DELAY Flags="\x01" Time="2"/>
×
×
  • Create New...