Jump to content
Macro Express Forums

Search the Community

Showing results for tags 'window activate'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News and Information
    • Guidelines for all Forums
  • Community Forums
    • Macro Express and Macro Express Pro
    • Macro Express 3.x
    • Macro Express 3.x Third Party Tools
  • Private Forums
  • Forum Archives

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 3 results

  1. Self-taught very basic Macro Express hack. Been running ME for years. Mostly to rename/number lists of files. Upgraded to W10 & then ME 5.1 couple months ago. Saw that when i upgraded to 5.1, the variables changed format from T%1% to %T[1]%, and the upgrade seemed to have automatically upgraded all my macro variables. So far, so good. Everything kept working fine. Then, about a week ago, when i went to run macros that have been running fine since the upgrades, i started getting this error: The following error was encountered: Undefined variable or the variable is the wrong type "20results" Macro Name: File REPLACE jpeg with jpg Line Number: 2 Here are the first three lines of that macro: VARIABLE SET STRING %T[6]% to topmost window title WINDOW ACTIVATE %T[6]% WAIT FOR WINDOW TITLE %T[6]% I then upgraded from ME 5.1 to 5.2.0.1 - no change. Still getting the errors. The thing is, they worked one day. Didn't work the next. These macros were written a long time ago, and have been running fine for years. When i remove the VARIABLE SET STRING command and the remaining occurrences of the focusing algorithm: WINDOW ACTIVATE %T[6]% WAIT FOR WINDOW TITLE %T[6]% the macros still work fine. My goal with these lines is to focus the macro on the Windows Explorer window where the files are and then wait for it to be active. Otherwise, because sometimes the renaming changes the order of the files, and windows now insists on refreshing the view every time there's a change, sometimes the refresh takes longer than i have timed for in the macro, and the macro starts working on the wrong file. This was my solution since probably ME 2 or 3 to keep the macro and the window in sync. What am i doing wrong? Is there a better way to do this? Any thoughts would be greatly appreciated.
  2. Self-taught very basic Macro Express hack. Been running ME for years. Mostly to rename/number lists of files. Upgraded to W10 & then ME 5.1 couple months ago. Saw that when i upgraded to 5.1, the variables changed format from T%1% to %T[1]%, and the upgrade seemed to have automatically upgraded all my macro variables. So far, so good. Everything kept working fine. Then, about a week ago, when i went to run macros that have been running fine since the upgrades, i started getting this error: The following error was encountered: Undefined variable or the variable is the wrong type "20results" Macro Name: File REPLACE jpeg with jpg Line Number: 2 Here are the first three lines of that macro: VARIABLE SET STRING %T[6]% to topmost window title WINDOW ACTIVATE %T[6]% WAIT FOR WINDOW TITLE %T[6]% I then upgraded from ME 5.1 to 5.2.0.1 - no change. Still getting the errors. The thing is, they worked one day. Didn't work the next. These macros were written a long time ago, and have been running fine for years. When i remove the VARIABLE SET STRING command and the remaining occurrences of the focusing algorithm: WINDOW ACTIVATE %T[6]% WAIT FOR WINDOW TITLE %T[6]% the macros still work fine. My goal with these lines is to focus the macro on the Windows Explorer window where the files are and then wait for it to be active. Otherwise, because sometimes the renaming changes the order of the files, and windows now insists on refreshing the view every time there's a change, sometimes the refresh takes longer than i have timed for in the macro, and the macro starts working on the wrong file. This was my solution since probably ME 2 or 3 to keep the macro and the window in sync. What am i doing wrong? Is there a better way to do this? Any thoughts would be greatly appreciated.
  3. I am working on a macro that just needs to run in the background... mostly. The problem is that I have to switch to a set program, do the commands and get back to my last window used. I have the macro activate the window I need it to for the actual commands, but I can't figure out how to get back to my last used program for me automatically. I could be surfing the net, watching a video, playing a game, so it could be a different window title or program all together that I want to get back to. The <ALTD><TAB><ALTU> command doesn't work. (Also tried running as admin). I wouldn't mind using an "activate window" command, but I need to be able to copy the current window title into a string or variable and call it back as the window to swap to since it won't have the same title each time. Any ideas on how to get something like this to work? Thanks Dylan
×
×
  • Create New...