Jump to content
Macro Express Forums

Windows 11 ( last updated as today...) macro does not start...

Recommended Posts

Hi everyone,


The problem:   macro ( activation hotkey ) does not start when a system windows is focused  ( like the task manager ) !

I tried search in the forum for known problems in win11 but could not really find any  so I did post...


ME 6 pro

Windows 11 Professionnel  / 22H2   build: 22621.1413

( My exprerience on ME:  ME3 pro ... ME6 pro    since year about 2000... so quite a long time used...)


I also tried with some security system windows ... same problem.

And macro is working fine when such system windows are closed.

This problem happend with all my hotkeys macro so apparently it is not depending on my macro.


So it is just a general question if some of you can try on your win 11  + a system windows open like for exampl the task manager ...

Thnaks for replies

( french mothertongue...  my english so...so...)


Link to comment
Share on other sites

I tried triggering a hotkey macro in the Windows 10 task manager, and nothing happened.


It looks like certain system windows block Macro Express, although not all system windows. At least in Windows 10.


For example, I can trigger a Macro Express script when this window has focus:




Link to comment
Share on other sites

Hi Arcantor ,

thanks for your reply and trial...  good to know that i am not the only one...

-sounds like it is probably a main problem  ( or a bug ) to be worked on by the macro-express developer team...

If some other user can confirm same problem...  on same windows builds ( or other builds may be same as well )

Link to comment
Share on other sites

You must not have searched very long because this topic was recently covered here in the forum regarding the Task Manager. There are problems with running macros in UWP apps but the bigger one is that MEP will not run in sensitive apps where they could be used to compromise systems like a virus. Most times the solution is to configure MEP to run with elevated privileges, AKA "Run as Administrator".

Link to comment
Share on other sites

Thanks Cory ( and other members replies)  for informations. 

In fact, on my win 11 system,  almost all windows-menu will prevent ME to start  ( like the Start-menu , or  param panel config ( shortcut win-i )

... i did not try all win screens...  but looks like many does same problem. 


win-e  / Explorateur is ok.
win-w  / Widget page is also ok.


Now, Cory, you said " the solution is to configure MEP to run with elevated privileges, AKA "Run as Administrator". "

So I did try / run ME in admin mode, here is my results:

Task manager :  OK , ME start

Win Params panel ( win-i ) :  NO start   

Win Params sub menus :  all NO start

Win Start panel:  NO start

win-a :  NO start
win-n :  NO start

( this is only a partial test / I did not try all system windows... )


Conclusion in my windows11/build/release: run as admin, at this point, will only add a solution for the task manager page. So not much difference.


Maybe something to work on for the ME developer team next release ?

Nice day to everone.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...