Jump to content
Macro Express Forums

Import Problem "read Beyond End Of File"


Recommended Posts

When trying to import a specific macro I get the error message "could not import macros due to the following error: Read beyond end of file"


I then went into the macro and tried to copy the commands into a new macro on the new computer. It didn't copy correctly. The original command line when pasted into notepad is:




This should have pasted back into ME as:


    Variable Set String %T99%"fbe"


Instead it pasted as:


    Variable Set String %T99%"fbe>"


This happened to all of the other TVAR2 lines as well. All of the other lines that were not TVAR2 copy over fine.


Any idea as to what is going on and how to fix it?

Link to comment
Share on other sites

Just found out that the 2 issues may not be related. When I was copy the command lines into Notepad I can copy them back fine. However when I send them through Outlook it removes a little box from between the fbe and the >.









So that is one mystery solved. I still am stumped with the importing problem though.

Link to comment
Share on other sites

The character in question is an ASCII SOH, used in many commands. you can see it from the Direct Editor, which, among other things, is used to view the native Macro Express language.


It seems that the macro you are importing (or the library itself) may be corrupted. Try exporting the macro as a playable and then import the playable.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...