Jump to content
Macro Express Forums
Magic

Time Settings For The Scheduler?

Recommended Posts

Maybe I'm stupid and/or blind but I can't find the 24h display for the scheduler.

I want a macro to go at 19:00 (or 07:00 PM) but I can't get the PM (or 19:00)!

 

Am I missing something? :huh:

Share this post


Link to post
Share on other sites

Hi! I have an older version of MacroExpress, so my windows may not look quite the same as yours.

 

I got to this dialog by looking at the script in the scripting editor, clicking the "properties" tab on the upper left, checking the scheduling checkbox and hitting the "Set schedule" button:

...

 

Erg, upload doesn't work, hot-link doesn't work, let's try this:

 

The "AM/PM"

 

And here's how I got there:

Step 1

Step 2

Share this post


Link to post
Share on other sites

hmmm strange.... I found the scheduler already but I can't choose between AM or PM!

I just see a time after the 12 the 01 starts again.

 

I seem to have weird problems with ME! :P

Share this post


Link to post
Share on other sites

Magic,

 

Check to see how your system time is being displayed (My Computer|Control Panel|Regional Options). Macro Express uses this setting.

Share this post


Link to post
Share on other sites

Floyd,

 

I already checked that and my time settings are: HH:mm:ss (HH being the 24 hour option).

 

I'm at work now and downloaded the trial and I have the same thing, but the timesettings are the same HH:mm:ss

 

I'm the only one that has that problem with the latest version? :huh:;)

Share this post


Link to post
Share on other sites

A 24 hour clock setting does not utilize the AM or PM designator. The time displayed should simply be in the range of 00:00:00 and 23:59:59.

Share this post


Link to post
Share on other sites

well I can't choose a number higher than 12...... <_<

 

I will try to set the systemclock to hh (forcing to use AM/PM) maybe that does the trick.

 

edit: well, it does work when I set the systemclock to hh:mm:ss!

I now have the AM and PM! :)

 

I'll report this to insight, maybe they can fix this in a next release :)

Share this post


Link to post
Share on other sites

hhmmm ...

 

I have my system clock set to HH:mm:ss also and am having no problems with hours > 12. What O/S are you using? Which schedule are you trying to set?

Share this post


Link to post
Share on other sites

really? hmmm........

 

I'm using Win XP Pro with SP2.

 

I have a macro which opens a newsprograms (Newsleecher) and update my subscribed groups.

 

I choose "daily" in the schedule options.

 

"play macro indefinitely" is marked and the date at "start on" is set to 8/14/2004

 

I've entered a time and marked the "selected days"

 

I switched back to HH:mm:ss and I can't get any hours >12.......

Using hh:mm:ss wouldn't be a problem but it is kind of strange...... :lol:

 

p.s. I installed the trial version at work today (XP pro with SP1) and also the same problem with HH:mm:ss......

 

Are you also using the latest version? (3.5b build1 3.5.2.1)

Share this post


Link to post
Share on other sites

Found the problem. The past couple of days I've been using one of my laptops with an earlier version of Macro Express. When I loaded the latest version the problem that you are encountering showed up. Thanks for jogging my memory about which version I was using!

 

I have reported this bug to Insight.

Share this post


Link to post
Share on other sites

Is this still a problem??

I am using version 3.5.2.1 on XP and I cannot get any scheduled macros to work in the mornings!! :unsure:

( I don't like mornings either)

If I enter 21 in the scheduler, it changes it to 9 and the macro runs at 9pm. If I enter 9, the macro still only runs at 9pm

Thanks

David

Share this post


Link to post
Share on other sites

Yes, the 24 hour clock is still a problem. Chances are it will be fixed in the next update. However, I am unsure of when Insight is releasing the next update. The last update was Aug-13-2004.

 

That being said, I was under the impression that only values > 12 were a problem.

Share this post


Link to post
Share on other sites

HI, I have scheduled a macro to adjust the clock in my computer every hour, with start at 12:00 and then every hour. But at 00:00 the macro doesn't run, see the fragment of the error log below.

The Macro only runs every hour from 01:00 to 23:00

 

code:

Synchronize System Time with ntp.lth.se

<SYSTIMESERVER:ntp.lth.se>

 

19-10-04 21:00:05 Macro "Time_Adjust" Started

19-10-04 21:00:05 Macro "Time_Adjust" Completed

19-10-04 22:00:05 Macro "Time_Adjust" Started

19-10-04 22:00:05 Macro "Time_Adjust" Completed

19-10-04 23:00:05 Macro "Time_Adjust" Started

19-10-04 23:00:05 Macro "Time_Adjust" Completed

20-10-04 01:00:05 Macro "Time_Adjust" Started

20-10-04 01:00:05 Macro "Time_Adjust" Completed

 

regards Lars

Share this post


Link to post
Share on other sites

Hello Lars!

 

If another macro is not scheduled to run at that time, I wonder if it could be a symptom of the 24 hour clock problem that is being discussed in this thread. Did you report this to Insight Software Solutions?

Share this post


Link to post
Share on other sites
Magic wrote
Never got a reply regarding the bug though...
Which bug question was missed?

 

the one with the 24 hour bug....

 

reported it a few months ago but never got any response... <_<

Share this post


Link to post
Share on other sites
HI, I have scheduled a macro to adjust the clock in my computer every hour, with start at 12:00 and then every hour. But at 00:00 the macro doesn't run, see the fragment of the error log below.

The Macro only runs every hour from 01:00 to 23:00

 

code:

Synchronize System Time with ntp.lth.se

<SYSTIMESERVER:ntp.lth.se>

 

19-10-04 21:00:05 Macro "Time_Adjust" Started

19-10-04 21:00:05 Macro "Time_Adjust" Completed

19-10-04 22:00:05 Macro "Time_Adjust" Started

19-10-04 22:00:05 Macro "Time_Adjust" Completed

19-10-04 23:00:05 Macro "Time_Adjust" Started

19-10-04 23:00:05 Macro "Time_Adjust" Completed

20-10-04 01:00:05 Macro "Time_Adjust" Started

20-10-04 01:00:05 Macro "Time_Adjust" Completed

I just chekked ME 3.5c still contains the schedule bug, mentioned back in october for 3.5b.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...