Jump to content
Macro Express Forums

Confused By A Macro Suddenly No Working


Jds11
 Share

Recommended Posts

I am a longtime Macro Express user. My primary use of macros is in a Library Management Software System called "Voayger". I'm wondering if anyone else has experienced something similar to what I am experiencing.

 

Several months ago I developed a macro that permits me to print a Voyager screen of information with a smaller Print font than the default font. It worked fine and I have actually sent the macro to others who have been able to use it without incident.

 

Today, suddenly, the macro no longer works. When I press the activation key (Ctrl-F12) the running icon shows up, but, as far as I can tell, the macro does not initiate any of the key strokes called for.

 

I have tried a number of things without success including the following:

 

Instead of using the macro from the file I usually have open, I opened another file that also contains the macro. When I run the macro from this file it works fine.

So, then I thought, OK, I'll delete the macro as it currently exists in the file I regularly use and then re-import it from the file from which I was just able to use it. But, when I did this, and tried to run the newly imported Ctrl-F12 macro, it would not work.

 

All the other macros that I've tried -- in my regular macro file -- have been working fine. I then wondered if I had too many macros in the file and that somehow this was having this wierd effect on this one macro. So I deleted a number of obsolete macros -- ones that I had deactivated, but had not yet removed. But deleting these had no effect.

 

Does anyone out there have any suggestions as to how to deal with this issue.

 

Thanks.

Link to comment
Share on other sites

Thanks to the one poster who suggested that I might have another macro with the activation key of Ctrl-F12. That wasn' t the case, exactly, but I did discover what the problem was.

 

The Ctrl-F12 macro not running was the result of another macro, with the activation key Alt-o (the letter "o") conflicting with the start of the macro I was trying to run (using the activation key Ctrl-F12)

 

The beginning of my Ctrl-F12 macro was a "Text type" command that started with "Alt-o". Apparently, when those key strokes were being executed Macro Express thought that it was being asked to run the macro with the activation key Alt-o.

 

This sounds like trying to run a macro within a macro. I was not aware of this being able to happen in this fashion. The way I would normally call up a macro to run within a macro would be to use the "Macro Activate" command and choose, from a menu list, the name of the Macro I wanted to run.

 

Anyway, when I deactivated the "Alt-o" macro, the "Ctrl-F12" macro worked fine.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...