Jump to content
Macro Express Forums

Trouble Recording Control-d, Not Holding Down Cntl


Gerry Peters
 Share

Recommended Posts

I'm having trouble recording a CONTROL-D. Using the wizard to record

keystrokes (no mouse), it appears like when I hit CONTROL-D, it records it

as hitting the CONTROL key and letting it up and then hitting the D. I tried

using direct editor to change it to hold control down and it didn't seem to

work. I ran into the same problem with ALT F4, which is a common technique

to close a window or exit a program. Is there some technique to this, did I

not hold the Control key down long enough or something?

 

--

Gerry Peters

Midi Magic Studio

<http://gprecordingstudio.com>

Album Productions and Songwriter Resources

Link to comment
Share on other sites

Gerry -

 

Is this the line that is being generated when you press Ctrl+D? If so, then this is correct.

 

Text Type: <CTRL>d

 

From the Macro Express Explained book: Macro Express knows the Control, Alt, and Shift keys are always used with one or more other keys. This is also true of the Win (Windows) key, with one exception, used by itself, it will engage the Start button on your Taskbar. When Macro Express sees something like <CONTROL><HOME>, it automatically holds the <CONTROL> key down while hitting the <HOME> key, then releases it. This is true of any combination that use these keys. <CTRLD><SHIFTD>P<SHIFTU><CTRLU> could be recorded as simply <CONTROL><SHIFT>P.

 

Hope this helps.

Link to comment
Share on other sites

Well this is quite strange. Here's a copy of my simple macro pasted from Direct Editor.

 

<SPEED:00001><TEXTTYPE:<F4>><MSD:0451><TEXTTYPE:<F4>><MSD:1882><TEXTTYPE:<CTRL><F4>><MSD:1401><TEXTTYPE:<CTRL>D>

 

The above macro works Ok until it gets to Control-D, at that point nothing happens. If I make a slight modification in Direct Editor, it works

 

If I replace

<TEXTTYPE:<CTRL>D>

with

Text Type: <CTRL>d

or

<TEXTTYPE:<CTRL>d>

it works

 

It's the after the D that makes it not work. This was recorded using the wizard. i'm a little curious why wizard recorded it wrong or what that means.

 

The program I'm using this macro for is Sonar, an audio recording program. It has key bindings, so I have Control-D assigned to "Save As". What's a little baffling is why the Control-F4 in my example above did work fine, but the Control-D didn't

 

Thanks,

 

Gerry Peters

Link to comment
Share on other sites

Hello Gerry!

 

Here is an excerpt from the Macro Express Explained book that illustrates why you were having a problem:

 

There may be instances where an uppercase character confuses the target application. When you Text Type an uppercase "F" the following is sent by Macro Express:

 

<SHIFTD>f<SHIFTU>

 

Think about this for a moment. For you to type an uppercase "F", you must hold the Shift key down, hit the "f" key, and then let go of the Shift key. Macro Express must do this also. So, when you Text Type "<ALT>F" this is what is sent internally:

 

<ALTD><SHIFTD>f<SHIFTU><ALTU>

 

The need to add shift keys may confuse an application's menu, so sending a literal lowercase "f" will avoid the need for them. When you Text Type "<ALT>f" only the following is sent:

 

<ALTD>f<ALTU>

 

Let's go back to the difference between sending a single "<ALT>f" (which you just saw) or double "<ALT><ALT>f" to activate a menu bar and choose, in our example, the File menu. Most of today's applications will work just fine with the former. There may be exceptions. When you find them, try the latter combination. It will send:

 

<ALTD><ALTU>f

 

That is correct. Sending two "<ALT><ALT>" keys in a row sends "<ALTD><ALTU>". Again, most applications think this is just fine, and will activate the chosen menu. Try both of these menu-activating keystrokes manually to discover which works best for your application.

 

It bears repeating that Macro Express needs to do exactly what you do to send keys to an application. Remembering this will make working with Macro Express less harrowing.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...