Jump to content
Macro Express Forums

Just Installed Cant Get Macro Window Only Tray Ico


Recommended Posts

Hi all, excited about the product but it won't do anything for me. I'm a web & software developer so tech talk is welcome.


I installed the product, restarted, i see the red and blue icon in the system tray, left clikc/double clikc on it does nothing, right click on it gets Suspend Macro Express thru Terminate Macro Express, i even installed the macexp3.chm file directly from the website, but i'm still stuck.


The Tutorial section mentions 3 ways to make a macro and i can not find nay of them. Making a Scheduled MAcro section mentions the Macro Express Explorer menu, but theres no window with any such menu. When i run MacExp.exe only the systray icon shows up. ow can i try the software is it won't run?


I found Ctrl-Shift-Alt-W in the help section somewhere, and opening that gets me the Licencse Info window asking for name and code. If i enter my name and click OK thew program blows up abnormal termination. If i click Cancel to "continue with the 30 day trial period" nothing happens at all. My only non-standard features on my XP machine are that Firefox is my default browser, and i use High Contract Black #2 as my color scheme.


Please help, i need a macro for a client to run on my server in the next few days, thank you!


From my support request:

Platform: Windows XP Windows 5.01.2600 Service Pack 2

Memory: Total Physical: 1015 MB Starting Available: 483 MB Ending Available: 479 MB


Program: Macro Express Player v


Error Type: EStringListError

Message: List index out of bounds (0)

Address: 0x004216E1

Link to comment
Share on other sites


Make sure Cap Locks is off.

Try Ctrl+Alt+Shift+w.

Press and hold Ctrl.

Press and hold Alt.

Press and hold Shift.

Press w.

Release all.

If you get the License Info window, it has been in my experience that I'm trying to edit a macro without MacEdit.exe. Definitely click Cancel to "continue with the 30 day trial period", because the License Code is a fancy code that you get from Insight after purchase.


Do you have a MacEdit.exe file where the program was installed (e.g. "C:\Program Files\Macro Express"), which is the editor? If not, that's why you cannot edit. Try the Wizard install with Default.


Do you have a macex.mex file in your My Documents (e.g. "My Documents\macex.mex")? If not, that may be a clue too.


What type of installation did you do (e.g. Wizard-Default, Wizard-Custom, Automated)?



Link to comment
Share on other sites

I think there is a bug in the process of the install program:

Because I use the Windows colors scheme High Contrast #2 on my XP machine, when I ran the installer and clicked "Custom", I couldn't tell if the items were checked or not (black checkboxes on black background). Now, I did NOT touch any of the checkboxes, then I hit Back and changed to Standard/Default installation and continued. My best guess is that viewing the custom checkboxes clears them, and even if one goes back and chooses Standard Install at that point, I believe the boxes don’t get reset at that point, which is why nothing installed for me even though I chose Standard ultimately. I suggest you try this sequence and see if the WISE script might need a tweak somewhere.

To get my install to work, I changed color schemes, uninstalled completely, deleted the Program Files Macro Express folder, did a reinstall with Custom and all boxes checked, then everything has worked terrifically.

It's just extremely disorienting to install a product and not be able to do anything the online help says you can, don't ya know.

Link to comment
Share on other sites

Also, regarding the crash for those of you who also get it:



The crash you reported occurs when a license has not been entered, you bring up the license dialog, and close the license dialog by clicking the OK button instead of the Cancel button. This will be fixed soon.


Kevin Heaton

Insight Software Solutions, Inc.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...