Jump to content
Macro Express Forums

Send Multiple Emails To One Destination


Lars_Sandberg
 Share

Recommended Posts

Hi, sometimes I need to send huge amount of datas to customers.

Then I have to split a large zip-file at 50 mb or more, into multiple binary pieces of 5 mb. Each of these files I have to attach to an email (one by one), wich I send, then wait to the client recieved that file, then I can send the next binary part.

 

Since we don't have a ftp-server for now, I thought that ME could do this tedius task, and I tried following code:

 

// Email address

Variable Set String %T1% from Prompt

// Counter

Variable Set Integer %N1% to 0

// No of files

Variable Set Integer %N2% from Prompt

// Delay i sec

Variable Set Integer %N3% from Prompt

Text File Begin Process: "files.txt"

E-Mail Send: Know Recipients, Fixed Text, Attachments

Delay %N3% Seconds

Text File End Process

 

---------

<REM2:Email address><TVAR2:01:02:FEmail addressFFCenter:Center><REM2:Counter><IVAR2:01:01:0><REM2:No of files><IVAR2:02:02:FNo. of filesFFCenter:Center><REM2:Delay i sec><IVAR2:03:02:FDelayFFCenter:Center><BTFBEG:002:000001:000000:c:\Send\files.txt><EMAIL2:Center:Center:Center:Center:Center:Center:RNR1TO%T1%|%T1%;S1File %N1% of %N2%A2%T2%;F><DELAY:%N3%><BTFEND>

--------

 

I get an error: Exception 502 error: command not implemented (smtp authentication failed)

I have configured ME with smtp-server, login and password, so what is the problem?

 

I'm using ME 3.5b

 

regards Lars

Link to comment
Share on other sites

Double check the SMTP settings. In email clients, incoming email uses a POP3 server. Outgoing mail uses an SMTP server. Macro Express does not read incoming mail. Therefore it supports only the SMTP services.

 

One frequent mistake in configuring the Macro Express E-Mail preferences is to enter the information for the POP3 server instead of the SMTP server. It is usually necessary to enter a name and a password to authenticate the POP3 connection. However, depending on your ISP, it is often unnecessary to enter a name and password to authenticate the SMTP server. For example, in MS Outlook, it shows ‘User Information’, ‘Server Information’ and ‘Login Informaion’. However, the Login Information only applies to the POP3 server. When you click on the ‘More Settings’ button and then on the ‘Outgoing Server’ tab, you are given the opportunity to enter the settings for you ‘outgoing server (SMTP)’.

 

What all this means is that you may not need to put a checkmark in the Macro Express preference ‘Server requires authentication’.

 

Another thing to note: Some ISPs have configured their SMTP servers to not accept outgoing mail unless a check for incoming mail is done first. If this is the case, you will need to work with your ISP to find a configuration that will work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...