Jump to content
Macro Express Forums

Opening properties on a macro


blopib
 Share

Recommended Posts

Hi

Is there someone who experience the same problem as i, when i click to open properties on a macro it takes about 20-25 sec. for it to be opened?

I have 85 macros in my mex file, has that something to do with it? The problem has started somewhat in the latest months, i have made a couple bigger kind of macros under this period. It's just this problem, everything else works fine.

 

 

I must stop hanging around here in my sparetime. Now i'm going to play some Call of duty4, it's has some really nice grafics! B)

Link to comment
Share on other sites

Hi

Is there someone who experience the same problem as i, when i click to open properties on a macro it takes about 20-25 sec. for it to be opened?

I have 85 macros in my mex file, has that something to do with it? The problem has started somewhat in the latest months, i have made a couple bigger kind of macros under this period. It's just this problem, everything else works fine.

I must stop hanging around here in my sparetime. Now i'm going to play some Call of duty4, it's has some really nice grafics! B)

I've not experienced this, even with macro libraries (mex) with more than 85 macros.

Link to comment
Share on other sites

Does restarting Macro Express help? Some people leave their computers on 24x7. Is your computer a desktop or a laptop/notebook? When you close a laptop it hibernates or sleeps. When a laptop is restarted it loads things where it left off. (Desktops have similar features but they are not used by default.) In short, do you restart Windows and consequently Macro Express periodically?

 

If you leave your computer running continuously for long periods of time you may benefit by creating a scheduled macro that contains a Restart Macro Express command. Set the schedule to run at time that you are not likely to be using the computer; 2:00 AM perhaps.

 

Have you emptied the Macro Recycle Bin inside Macro Express? You may have more macros in your macro file than you expect. There may only be a few active macros but you may have many more that you have deleted but not removed from the Macro Express Recycle Bin. When you edit a macro or when a macro runs Macro Express has to skip over the macros in the Macro Recycle Bin. Normally this is very fast and unnoticeable but if you have a large number of macros then it can start slowing down.

 

How large is your macro file and macro cache? Check the size of your macro file using Windows Explorer/My Computer. If your macro file is larger than 1 Megabyte (1024 K), and if you have not adjusted the size of the cache before, you may benefit from increasing the size of the Macro Cache. Click Options, Preferences, Caching, and change the number of kilobytes used for the cache.

 

However, if your computer is fast enough, and if you have macros that you don't use very often, a cache that is smaller than your macro file is okay. Today my main macro file contains 1098 macros with 343 more in the Macro Recycle bin and is nearly 4.5 megabytes in size. My Macro Cache is still set at the default value of 1024 K. This works great for me.

 

When is the last time you accessed the macro? Macros are saved in the macro cache in the order they are used. If there isn't room in the cache for a new macro then macros that have not been accessed for a long time are removed from the cache and the new one is added. When you run or edit a macro if it has not been accessed for a while then Macro Express needs to find room for it in the cache. This can cause some delay.

 

Rebuild your macro file. Occasionally a macro file will become corrupted in some way and can only be fixed by completely rebuilding the macro file. To do this follow these steps:

  1. Create a new macro file by clicking New, Macro File
  2. Import all of your macros from your existing macro file by clicking File, Import, Import Macros
  3. Recreate your macro categories and move your macros into them
  4. You will likely need to rebuild your popup and floating menus

This solution is extreme but it often works wonders.

 

We would like to hear from you about whether or not any of these solutions help.

Edited by kevin
Link to comment
Share on other sites

Hi Kevin

 

I still have these problems, but i've found out that it's different between the macros, look further down.

 

Does restarting Macro Express help? Some people leave their computers on 24x7. Is your computer a desktop or a laptop/notebook? When you close a laptop it hibernates or sleeps. When a laptop is restarted it loads things where it left off. (Desktops have similar features but they are not used by default.) In short, do you restart Windows and consequently Macro Express periodically?

 

If you leave your computer running continuously for long periods of time you may benefit by creating a scheduled macro that contains a Restart Macro Express command. Set the schedule to run at time that you are not likely to be using the computer; 2:00 AM perhaps.

I shut down my computer almost every night.

 

Have you emptied the Macro Recycle Bin inside Macro Express? You may have more macros in your macro file than you expect. There may only be a few active macros but you may have many more that you have deleted but not removed from the Macro Express Recycle Bin. When you edit a macro or when a macro runs Macro Express has to skip over the macros in the Macro Recycle Bin. Normally this is very fast and unnoticeable but if you have a large number of macros then it can start slowing down.

I've emptied the macros recycle bin, it wasn't so much in there.

 

How large is your macro file and macro cache? Check the size of your macro file using Windows Explorer/My Computer. If your macro file is larger than 1 Megabyte (1024 K), and if you have not adjusted the size of the cache before, you may benefit from increasing the size of the Macro Cache. Click Options, Preferences, Caching, and change the number of kilobytes used for the cache.

 

However, if your computer is fast enough, and if you have macros that you don't use very often, a cache that is smaller than your macro file is okay. Today my main macro file contains 1098 macros with 343 more in the Macro Recycle bin and is nearly 4.5 megabytes in size. My Macro Cache is still set at the default value of 1024 K. This works great for me.

The mex file is 131kb and the Total physical memory is 1048048kB, free 597964kB, Systemcache 483456kB.

 

When is the last time you accessed the macro? Macros are saved in the macro cache in the order they are used. If there isn't room in the cache for a new macro then macros that have not been accessed for a long time are removed from the cache and the new one is added. When you run or edit a macro if it has not been accessed for a while then Macro Express needs to find room for it in the cache. This can cause some delay

I can't see any problem with this, i've accessed both macros regulary.

 

Rebuild your macro file. Occasionally a macro file will become corrupted in some way and can only be fixed by completely rebuilding the macro file. To do this follow these steps:

Create a new macro file by clicking New, Macro File

Import all of your macros from your existing macro file by clicking File, Import, Import Macros

Recreate your macro categories and move your macros into them

You will likely need to rebuild your popup and floating menus

This solution is extreme but it often works wonders.

I wait a little with doing this. We have so much work going on now with the help of macros.

Now what i've come up with, i've found out that it's different between the macros.

I have one macro that contains 5583 characters and it opens properties directly, i have another one wich contains 389 characters and it takes 17seconds to open up properties, regardless of any reboot, it always takes the same time in both cases. Both macros works fine, so i think it's very strange and i can't see any reason for this.

 

What should i do next. What do you think about all this Kevin? Should i post the code of these two macros, maybe not here, to you directly Kevin? This is not a big problem more of a strange annoying kind of type.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...