Jump to content
Macro Express Forums

Clipboard commands don't work in macro script pane on Windows XP Pro SP2 with ME v3.7a


Recommended Posts

Does anyone have experience with this problem with the clipboard commands, or should I report it as a bug?


This problem just started when I moved to a new PC. The old PC was running Windows XP Pro SP1. The new PC is running SP2. Both PC's used macro express version 3.7a.


I have three macros (one command in each macro) set up with the following hotkeys:

F2 = <CLIPT> (clipboard cut)

F3 = <CLIPC> (clipboard copy)

F4 = <CLIPP> (clipboard paste)


These macros work correctly in all of my applications except within the the macro express scripting editor's macro script pane. When I'm writing or editing macros in the script pane, I want to use these macros so that I can have "one touch" buttons to cut, copy, or paste commands within the script. Within the macro script pane, the macros don't cut, copy, or paste. But these macros do work in other parts of macro express; for example, if I am within the text type command dialog box defining keystrokes, all three of these macros work correctly.


These macros worked fine in the script pane on my old PC. On the new PC, I tried increasing the clipboard delay setting in the global preferences but it did not make a difference.


Even thoug the clipbaord macros are not working in the script pane, the hotkeys are definitely invoking the macros when I'm within the script pane; the problem is that the three clipboard commands are not acting on the clipboard.


Ultimately, I dealt with this problem by redefining each macro to not use the clipboard commands, but instead to type the clipboard keystrokes (ie, control x, control c, control v). As long as I have the global text type delay set to at least 325 microseconds, the keystroke macros (using the same three hotkeys) now cut, copy, and paste within the macro script pane.


Does anyone know why I now need to use the keystrokes instead of using the clipboard commands?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...