Jump to content
Macro Express Forums

Scheduled macro not invoked for time out option


ejs
 Share

Recommended Posts

I have a macro where the schedule it is set so the macro runs after a 1 minute time out (that is, after one minute of keyboard and mouse inactivity).

 

But the macro never runs after a sufficient amount of inactivity has occurred.

 

It's definitely a problem with the scheduling function detecting the timeout. Other than that, I know the macro itself is good; it runs correctly when I invoke it from the hotkey combination.

 

Also, if I change the schedule from the 'time out' selection to the 'other' selection, the macro runs according to schedule.

 

Is anyone aware of problems like this, and whether there's anything I can do to fix it? I already tried checking off the box in the schedule dialog box for running the macro indefinitely, so this is not an issue on the time range or the date range.

 

I am running macro express 3.7a on windows XP Pro service pack 1.

 

Thanks

Link to comment
Share on other sites

I seem to remember some discussion on time outs in here before but I can't find them now. I don't use these very often so I don't have much advice other than basic troubleshooting. It seems something is making the system think there is keyboard or mouse activity and it's keeping you awake. I would try booting into safe mode and running it there so only essential processes not start. If it works there use MSConfig to selectively disable them until you find which is the culprit.

 

Now you don't have any other scheduled macros running do you? I don't know but it would seem plausible that a macro that moves a mouse or types a keystroke would reset the inactivity timer. Might try disabling all your other macros.

 

Oh, and make sure there's no cat hair in your mouse. I've seen machines that will never go to sleep because there's a cat hair or fuzz in the laser port of the mouse. It's nearly imperceptible but it can cause the mouse to dance back and forth rapidly a tiny amount. Some good laser mice are so sensitive that vibrations like someone walking by can keep them up too. I have literally walked by a user's desk before and had the monitor light up in the middle of the night. And something like an out of balance fan on the users desk can keep it awake. Try unplugging the mouse altogether and see if that fixes our wagon.

Link to comment
Share on other sites

Thanks for the suggestions, but no improvement. I unplugged my mouse. I also exited Dragon naturally speaking and RSI guard, two programs which are involved in intercepting keystrokes and mouse control. I still cannot get the timeout/inactivity functionality to invoke the macro.

 

I'll open a bug report about this.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...