Jump to content
Macro Express Forums

How can I disable the 'enter' key from triggering a macro using shortkeys?


Recommended Posts

Hi all,

By default, MPro uses space bar and 'enter' key to tigger a maco using shortkeys. I was able to disable the space bar by simply adding a space in the 'invalid characters' box under activations --> shortkeys. How can I disable the use of 'enter' key from doing the same?

 

Any hep will be appreciated.

 

Thank you.

Link to comment
Share on other sites

Hi all,

By default, MPro uses space bar and 'enter' key to tigger a maco using shortkeys. I was able to disable the space bar by simply adding a space in the 'invalid characters' box under activations --> shortkeys. How can I disable the use of 'enter' key from doing the same?

 

Any hep will be appreciated.

 

Thank you.

 

Are you saying that macros to which you've assigned a shortkey are being triggered when you press Space followed by Enter? Or by one or other of these, which I believe should be the case?

 

What do you have as your Prefix or Suffix in Options > Preferences > Shortkeys? It sounds as if you're using a Suffix? If so, I'm not clear why you would want to disable those final activation keys?

 

Have you read the Help on this, as there are several points to watch out for?

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

The way i have always did it with MacroExpress (a while ago) and having to migrate from Perkect KB, I want a shortkey to trigger a macro only if it's followed by a ';' character. I do not want it to trigger followed by a space OR 'enter'.

 

I have a shortkey of 'sid'. If i type 'sid;' it expands to 'system identifier', but if i type 'the word sid means ...' i do not want it to expand in the middle of a sentance or at the end of paragraph followed by the 'enter' to start a new one.

 

In otherwords, I disabled use of space bar as a suffix but did not find a way to to disable 'enter'. Hope this clarifies my question.

 

Thank you.

Link to comment
Share on other sites

The way i have always did it with MacroExpress (a while ago) and having to migrate from Perkect KB, I want a shortkey to trigger a macro only if it's followed by a ';' character. I do not want it to trigger followed by a space OR 'enter'.

 

I have a shortkey of 'sid'. If i type 'sid;' it expands to 'system identifier', but if i type 'the word sid means ...' i do not want it to expand in the middle of a sentance or at the end of paragraph followed by the 'enter' to start a new one.

 

In otherwords, I disabled use of space bar as a suffix but did not find a way to to disable 'enter'. Hope this clarifies my question.

 

Thank you.

 

OK, I see what you mean now. Can't think of an easy solution though. I use the Prefix method, so I'd be typing '##sid' whenever I wanted to get 'system identifier'. Are you firmly set on Suffixes with a semicolon activator? If you use that combination a lot, it seems to me that you're going to run into problems with words that happen to end in your shortkey string and could unwantedly trigger your macro.

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...