Jump to content
Macro Express Forums

create a new macro


Recommended Posts

I'm sorry, I don't understand. Are you trying to set the activation when creating a new macro from the Explorer? If you want no activation simply click on the "None" in the column titled "Initial Activation".

Link to comment
Share on other sites

the initial activation is first set to "hot Key"

so i have no chance to click somewhere with my mouse because this will get me a right or left mouse click as "hot KEY"

 

I'm not following you either. I don't see why you "have no chance to click somewhere" with your mouse. For a hotkey type of activation, just enter your macro name and choose the hotkey (in any order) and click OK.

 

If this still doesn't answer your question, please provide more details, including a screenshot or at least a step-by-step description of what you are doing and seeing.

 

MEPro-Activation-Yaqwa.jpg

 

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

I'm not following you either. I don't see why you "have no chance to click somewhere" with your mouse. For a hotkey type of activation, just enter your macro name and choose the hotkey (in any order) and click OK.

 

If this still doesn't answer your question, please provide more details, including a screenshot or at least a step-by-step description of what you are doing and seeing.

 

MEPro-Activation-Yaqwa.jpg

 

 

--

Terry, East Grinstead, UK

I think what he's saying is that when he is on the Create a New Macro window, he is unable to select from the left-hand menu of

activations. When he tries to click on any of the selections, the HotKey window automatically selects the mouse-button he's clicking as the

HotKey activation.

 

Right Mouse is an authorized Hotkey activation, but Left Mouse is not. You may want to try Left-Clicking the menu selection, even if your

mouse is using Left-hand settings (if that is the case you'll probably want to submit a bug report to ISS at www.macros.com/bugreport.htm

mentioning this particular issue in particular).

Link to comment
Share on other sites

ok

 

 

but i only get the second window - the first did not appear in my version

 

From your screenshot, the window you get is not my second window. Look more carefully at their respective titles. My first screenshot shows the situation when None is selected, not the default Hotkey. You are getting the correct Create New Macro window. So that's not the issue.

 

Are you saying that when you left click the None checkbox the Hotkey checkbox stays selected and is assigned to Left mouse? And similarly if you click the None checkbox with the right mouse you get Right mouse activation? If so, then that does indeed sound bizarre. I'm assuming you've re-booted your PC and are not getting any odd behaviour from your mouse in ME Pro or any other application?

 

Have you tried Tools > Restore Keyboard & Mouse Hooks ?

 

If the problem persists I'd try re-installing ME Pro.

 

Steve: Left mouse is apparently valid, although it has to be selected from the list.

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

Right Mouse will get me the right mouse key

left mouse click will do nothing

 

But - you know the text there :

it says "click in the box to the right......................"

but i must not click into the box on the right - when i click on "new Macro" the Focus IS in the box!

Maybe this is the problem

could it be that if you click on "new MAcro" the focus is on the left at "initial Activation" and not on the right directly in the box?

Link to comment
Share on other sites

Right Mouse will get me the right mouse key

left mouse click will do nothing

 

But - you know the text there :

it says "click in the box to the right......................"

but i must not click into the box on the right - when i click on "new Macro" the Focus IS in the box!

Maybe this is the problem

could it be that if you click on "new MAcro" the focus is on the left at "initial Activation" and not on the right directly in the box?

 

Yes. 'Click in the box on the right...' is probably an unnecessary instruction. But, as always, if it doesn't say right-click or middle-click it means a plain left click, so it can never do any harm. Perhaps sometimes the cursor might not be in that box by default.

 

You still haven't spelt out exactly what you are doing and what you are seeing. But I think you have misunderstood how to use this dialog. Simply do as I said in my earlier post, at step 1. As it says at the top of that window, 'Select an initial activation on the left.' So just left click None at bottom left if that's what you want.

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

Yaqwa in another post you said you're having trouble with left hand mouse configuration and ISS acknowledged this is a problem so don't you think it likely that this is the root of your problem? To test this please temporarily reconfigure you mouse for right hand use and follow Terry's instruction and see if that works.

Link to comment
Share on other sites

Hi Cory

 

Yes you are right -it is the same left /right click problem.

I reconfigured to right hand mouse and everything works fine.

So it is the same old problem.

 

So what next?

 

bugbase?

 

i thinkk my english is not really good enough to explain - can someone do it for me?

Link to comment
Share on other sites

Your English is difficult to understand but judging by the response from Chris in the other post they are aware of the problem and it should be fixed in the next release. So the next step is to wait.

 

In the mean time you can work around this problem by creating a macro and accepting any hotkey combination. Once the scripting editor opens go to the Activations tab and set the desired activation.

 

So what is your first language and where do you live? It's always interesting to know as we have a very geographically diverse group here.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...