Jump to content
Macro Express Forums

Getting text error when using with Mind Manager...

Recommended Posts

Hi All,

I recently got Mind Manager 8, a graphics and plugin-intensive program. It's a major resource hog.

I have a simple macro for on-the-fly note taking. It's shortkey-activated and types out

"On DDD, M/d/YY, @ t:"

It works fine in smaller apps, but does all kind of weird things when I'm typing into the notes area of a MM item. I assume that this is because MM is a HUGE program and maybe because there are so many behind-the-scenes processes going on?

Usually it will type out correctly except for leaving out several characters. Other times will type @#%) as though the Shift key was down when the numbers in the date and time are getting entered. One time it even typed the "t" instead of typing out the time...

I thought that there was a way to slow down the keystrokes for an individual macro, but I couldn't see how...


Ideas one what might cause this or how to fix it?

Note that this is not a RAM issue. I have 2 GB.


Thanks :) -steve

Link to comment
Share on other sites

If you do not want to type via the clipboard, as Cory suggests, try the Keystroke Speed command. This command accepts a value in milliseconds so a value of 50 is a fairly large delay. (The Delay after keystrokes setting in the preferences is in microseconds so 300 is a fairly small value.)

Link to comment
Share on other sites

Hy Guys,

Thanks for the replies. I haven't totally solved this, but I wanted to give feedback. Slowing down the macro speed didn't seem to help. In most similar scenarios I think it would, but not with Mind Manager. The only thing I can figure is that MM has some type of background process regularly cycling, that takes precedence over MacExpPro. What ever key command is being send to the key que by MEp gets "lost." If the MM event happens to occur right at the end of an operation that involves the Ctrl command, then the Ctrl key is left down and things really get screwed-up. Using the clipboard does work *much* better--still not perfectly though. Portions in the mddle of the "On DDD m/d/yy at HH:MM ampm:" don't get left out anymore with clipboard paste, but about one out of 10 times it will still get stuck in the Ctrl down position. I remedied this by including a Text Type command of: <CTRLUP><CTRLUP><CTRLUP>. This ensures that the Ctrl key isn't left down. Of course the macro still doesn't play properly during the one of of 10 times.... It just essentially aborts. I can live with that though :)

Thanks again :) -steve

Link to comment
Share on other sites

I have several macros for clients that fire keystrokes at Java applets which routinely ignore that what was typed at them. The only solution I found was to enter the text then read it back to make sure it was entered correctly. For instance I might tab forward and back then copy and compare. If not the same then I paste it again.


How is the control getting stuck if you are using Text Type command with the "Use Clipboard and Paste Text" option? I'm guessing you're not doing it this way but rather are pasting by using a CTRL+V. If that's the case try sing the method I suggested. Here's the code:

<TEXT TYPE Action="1" Text="Type something"/>

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...