Jump to content
Macro Express Forums

ShortKey Problem


Recommended Posts

Upon assigning an "ma" ShortKey activation to a macro, the following warning is displayed, even though I don't have any other activations that begin with "ma."

 

Anyone else?

 

Yes. I reported this as a bug and on 26th January ISS assigned it the tracking number [iSS6470].

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

Thanks!

 

Just out of curiosity, was it specifically an "ma" activation?

 

No, I've had this with several different shortkeys. Today for example it's happened each time I edited the macro to which I've assigned 'ms'.

 

FWIW, my prefix is ##.

 

And other macros use the following, starting with 'm':

m2, m3, ma, mebug, mgn, mgy, mhc, mj, mk, mm, mo, mp, ms, mt, mu, mv, mx, my, mz

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

No, I've had this with several different shortkeys. Today for example it's happened each time I edited the macro to which I've assigned 'ms'.

 

FWIW, my prefix is ##.

 

And other macros use the following, starting with 'm':

m2, m3, ma, mebug, mgn, mgy, mhc, mj, mk, mm, mo, mp, ms, mt, mu, mv, mx, my, mz

 

Try disabling all ShortKey macros that start with M but one, and see if the problem disappears. I suspect there will be no problem with only one macro. Gradually reintroduce your macros, and see if you can figure out the source. My guess is that you cannot have plain "M" as a shortkey if you have other Shortkeys that start with M. I am quite sure that this is true for prefix Shortkeys in general. I don't think it holds for suffix Shortkeys.

 

Hint: Consider changing the prefix to something easier to type: my two favourite prefixes are "q" and comma. Comma is great because no Shift key required; no words start with the comma; and even "bad" touch typists can usually hit it without looking at the keyboard. I once used Q as a prefix for a person who typed only with their left hand.

Link to comment
Share on other sites

We are now aware of two scenarios that cause the shortkey conflict warning message to appear when it may seem like it should not.

 

Scenario #1

A shortkey macro is created or saved that would be in conflict with another disabled ShortKey macro if it were enabled. For example, a macro exists with a shortkey activation of 'macr' but this macro is disabled. When you create and save a macro with a shortkey activation of 'mac' you will see the warning message.

 

Scenario #2

Using the suffix shortkey settings. You have one macro with a shortkey activation of 'macr'. The warning message comes up when you create or save a macro with the shortkey activation of 'mac'. If you are using the suffix shortkey options the macros 'mac' and 'macr' do not conflict because you have to type another letter after the shortkey before activation occurs. For example, 'mac ' or 'macr '.

 

 

The warning message is just that, a warning. It says "The ShortKey activation may conflict..." It does not say that it will conflict.

 

Macro Express Pro was designed this way to provide a warning in case you enable a previously disabled macro or in case you change the shortkey settings from 'suffix' to 'prefix' after a macro is written that causes a conflict with the new macro.

 

Please let us know if you are seeing the warning message in other situations. If so, it would be helpful if you sent your macro file via email to Insight Software Solutions support.

Link to comment
Share on other sites

We are now aware of two scenarios that cause the shortkey conflict warning message to appear when it may seem like it should not.

 

Scenario #1

A shortkey macro is created or saved that would be in conflict with another disabled ShortKey macro if it were enabled. For example, a macro exists with a shortkey activation of 'macr' but this macro is disabled. When you create and save a macro with a shortkey activation of 'mac' you will see the warning message.

 

Scenario #2

Using the suffix shortkey settings. You have one macro with a shortkey activation of 'macr'. The warning message comes up when you create or save a macro with the shortkey activation of 'mac'. If you are using the suffix shortkey options the macros 'mac' and 'macr' do not conflict because you have to type another letter after the shortkey before activation occurs. For example, 'mac ' or 'macr '.

 

 

The warning message is just that, a warning. It says "The ShortKey activation may conflict..." It does not say that it will conflict.

 

Macro Express Pro was designed this way to provide a warning in case you enable a previously disabled macro or in case you change the shortkey settings from 'suffix' to 'prefix' after a macro is written that causes a conflict with the new macro.

 

Please let us know if you are seeing the warning message in other situations. If so, it would be helpful if you sent your macro file via email to Insight Software Solutions support.

 

OK Kevin, I've done that for one macro that consistently gives the apparently invalid warning. As already mentioned, its activation is only by shortkey which is 'ms'. My 2-character prefix is '##'. None of the other 18 other shortkeys that start with 'm' which I listed are disabled.

 

Edit: I actually sent the code for that specific macro, but on re-reading I see you ask for the file. I don't think I want to send you my 600-macro MEX file, and I wouldn't envy you trying to make sense of it!

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

Try disabling all ShortKey macros that start with M but one, and see if the problem disappears. I suspect there will be no problem with only one macro. Gradually reintroduce your macros, and see if you can figure out the source. My guess is that you cannot have plain "M" as a shortkey if you have other Shortkeys that start with M. I am quite sure that this is true for prefix Shortkeys in general. I don't think it holds for suffix Shortkeys.

 

Hint: Consider changing the prefix to something easier to type: my two favourite prefixes are "q" and comma. Comma is great because no Shift key required; no words start with the comma; and even "bad" touch typists can usually hit it without looking at the keyboard. I once used Q as a prefix for a person who typed only with their left hand.

 

## suits me fine. Single finger, next to Enter. Even a 2-finger 'pecker' like me that's never mastered touch-typing can tap those in pretty fast.

 

In my case comma would be an unwise choice, because in full flow I occasionally skip the required space after a comma!

 

None of the shortkeys I listed include a single 'm'.

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

Issue [iSS6421] with the description "Assigned a shortkey 'ff' to a macro for a pop-up menu and got "The ShortKey activation may conflict with one or more macros" has been fixed (even though it is not listed in the release notest for v 4.0.2.1). So my first request it to make sure that the warning message is coming up incorrectly with the latest version.

 

I have tested the creation of shortkey macros using Macro Express Pro v 4.0.2.1 and, other than described above, cannot duplicate any problems.

 

I understand the reluctance to send macros that contain sensitive information. If you continue to see a problem perhaps you could make a copy of your macro, remove the macros or macro commands containing sensitive information, and send the edited macro file to us. Make sure that you can duplicate the problem in the edited macro file.

 

We appreciate any help you can provide to track down the problem.

Link to comment
Share on other sites

I actually sent the code for that specific macro, but on re-reading I see you ask for the file. I don't think I want to send you my 600-macro MEX file

The issue is not with the content of a specific macro. If the issue remains (see my other post) then it is related to all the other shortkey macros in your macro file (and possibly the Macro Recycle Bin). We need the macro file, not an individual macro.

 

One other point. Pasting a macro into the body of an email message is not helpful. The formatting of email messages alters the content of macros sent this way. The only reliable way to send a macro is to export it to a macro file (Click File, Export, Export Macros) and send it as a file attachment.

Edited by kevin
Fixed link
Link to comment
Share on other sites

OK, I've put another couple of hours into this. I've emailed Support an MEX file which includes all 132 of my macros that are activated with shortkeys (prefix ##).

 

Of those, the following 10 give apparently invalid duplication warnings: ms, t1, rs (disabled), rm, om, nt10r, my, mm, gm, 21.

 

Hope this helps to isolate the problem.

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

Terry and notbob:

 

Thank you for sending your macro files. We were able to identify and fix another problem with the invalid shortkey warning. The issue is caused when the shortkey activation is entirely included in another shortkey but not at the beginning of that shortkey activation. The invalid message was displayed for Terry's shortkey macro 'ms' because he had another macro named 'p8-msk'.

 

This has been fixed.

 

Notbob: We could not duplicate the problem by creating a shortkey macro of 'ma' with the macro file that you sent. I am guessing that the 'ma' is part of another shortkey macro that you chose not to include in the macro file you sent us. Could you please confirm this so we can make sure there is not another problem?

 

Thanks again for helping us track the problem down.

Link to comment
Share on other sites

Terry and notbob:

 

Thank you for sending your macro files. We were able to identify and fix another problem with the invalid shortkey warning. The issue is caused when the shortkey activation is entirely included in another shortkey but not at the beginning of that shortkey activation. The invalid message was displayed for Terry's shortkey macro 'ms' because he had another macro named 'p8-msk'.

 

This has been fixed.

 

Notbob: We could not duplicate the problem by creating a shortkey macro of 'ma' with the macro file that you sent. I am guessing that the 'ma' is part of another shortkey macro that you chose not to include in the macro file you sent us. Could you please confirm this so we can make sure there is not another problem?

 

Thanks again for helping us track the problem down.

 

Hey, that was fast work - well done and thanks!

 

Looking forward to the next release but meanwhile I'll try to avoid that issue.

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...