Jump to content
Macro Express Forums

subroutines


Recommended Posts

In a MEP macro I am using an Excel file in which I embed

a microsoft macro (VBA Sub).

I try to call the sub but MEP cannot find it.

So for now to get to the sub I click in excel Tools\Macro\...

How can I get the sub directly ?

 

Please help

 

yannis

Link to comment
Share on other sites

I once launched VBA macros in some Office app using the command line. I think it was Excel but I can't be certain. Might try that. I think I even posted about it back in the ME3 forum. But that was some time ago.

Link to comment
Share on other sites

I tried using "Program Launch" with

 

Application.Run "C:\XFIL\ER.xls!optimize"

It should have worked because MEP accepted it (when I left something

out will get "specify file")

and still I was getting at run time "cannot locate file)

Finaly I solved the problem by using the MS macro's short-cut

and Text type <CONTROL><SHIFT>N

Thanks for your help

Link to comment
Share on other sites

Sometimes you will need to actually specify the EXE in the run line of Application run and the parameters like the file name and macro in the parameters field. I don't know why this is but in same cases it seems necessary.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...