Jump to content
Macro Express Forums

Can't set text type delay to 0 with v3.7d...


TsunamiZ
 Share

Recommended Posts

I don't know the answer -- but the default text type delay is not 300 ms (milliseconds), it is 300 microseconds. In theory that's 3,333 characters per second. I'm curious how you are distinguishing between 3,333 and "something even faster"? What are the symptoms of the problem you are having?

Link to comment
Share on other sites

I upgraded from 3.7c to 3.7d and I can't set text type delay to 0 anymore. Even if I uncheck it or set it to lower number, it still behaves as the default 300ms. Can this be fixed?

 

 

You could try the Keystroke speed setting:

 

<SPKEY:0000>

 

Just copy that and past it at the top of the macro and see if that remedies it. Its not the ideal fix because you shouldn't need that at the beginning of every macro, but it may work.

 

 

Another option would be to uninstall 3.7d and do a fresh 3.7d install rather than a 3.7c to 3.7d upgrade install. The registries could be messed up not allowing the defaults to be set. I have some notes on how to changes these using the Macro express registry read/write commands, but I don't have access to them at the moment. I'll post them if there is anything useful.

Link to comment
Share on other sites

Any time Macro Express finds a value of 0 for the Text Type delay setting in the preferences, it changes it to 300.

 

You can uncheck the 'Use Text Type delay' to remove the delay altogether. Or, you can change the value to 1.

 

It is a known issue that Macro Express v 3.7 and later process Text Type commands slightly faster than previous versions. To fix this issue and improve reliability the Text Type delay setting is now 300 microseconds. Keep in mind that, as rberg pointed out, this is a delay of 0.0000003 seconds.

 

I find it highly unlikely that you would be able to notice any difference between 0 and 300 microseconds.

 

Versions of Macro Express prior to v 3.7 had similar delays, but they were contained within the Text Type part of the program itself.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...