Jump to content
Macro Express Forums

Uncontrolable MEX Pro Crashs in Win 7 x64

Recommended Posts

I used to stop the running man with rightclick in the tray under Macro Express (not Pro) and Win XP. This wasn´t possible anymore in MEX Pro. The Hotkey to abort macros refused to work also. Whenever the man couldn´t stop running and clicking on it did not work i killed the MacExp.exe and restarted Mex Pro.


This is not working in Win 7 anymore. If the man runs endlessly and you click in the taskbar the taskmanager crashes and you can´t kill the MacExp.exe anymore. Restarting the pc is than the only escape!!!


If you press CTRL + SHIFT + ESCAPE immediately without clicking in the tasbar the chances to kill the process are much higher!!

Can anybody confirm this?


Still i wonder what is, if there is a proper way of ending a troubled macro? The kind of macroerror i´m talking of is easy to reproduce. Use an infinitetly "Wait for windows" command with an nonexisting windowname. Can anybody help me?


Thank You


Link to comment
Share on other sites

In lieu of more expert opinion, the running man has been a problem for most of us. Your problems seem more extreme. As an interim measure you could try Process Explorer as an emergency alternative to the crashed Taskbar. I do not know if it will start up and show processes under your circumstances. Their pskill looks like it may be a good candidate too!


Although the PE link is MS, SysInternals used to be an independent group that wrote a whole suite of useful tools. You can find the latest info and links here.


(edit) I can't say this will work for anyone else but this is what I tried:

Copy pskill.exe into the Windows folder

Start/Run (the one bottom left of screen)

Type: pskill -t macexp.exe


This kills exp and edit processes

Edited by JohnS
Link to comment
Share on other sites

You might be seeing a ghost of Forrest past.


First off I'm in W7 and I can click Forrest (running macro icon) and terminate my macros. Also my pause and abort keys work just fine as well and that's really the best way to terminate a macro. My point is that there's probably something up with your machine with regards to stopping a running macro. If it's really running...


I have raised an incident with ISS on a problem which I've mentioned here before where Forrest gets stuck in the system tray with no macro running. Often happens with Remote Desktop sessions which have been dropped and reconnected. The telltale is that if one hovers over Forrest no balloon pops up. Terminating and launching MEP is the only way to clear it.


But as to why you can't pause or abort a macro with hotkeys I can't figure. Might want to contact ISS support. Also make sure you have 4.1.5 as an earlier version had the molasses problem and with that the abort keys would not work when it was experiencing a slowdown.

Link to comment
Share on other sites

Thank you so much guys!


@ JohnS: I already tried the process explorer. It crashes with the taskbar, just like the taskmanager. I will try the pskill.exe


@ Cory: Dear Cory, how sweet! Always there, when i need you. I am very jealous of how you can handle this beast called forrest. I don´t get it. My Win 7 x64 installation is brandnew and i use MEX Pro Could you reproduce the running and stopping of forrest with my described one command macro:


Use an infinitetly "Wait for windows" command and use an nonexisting windowname.


At least my forrest is running for a reason! <_<



Link to comment
Share on other sites

I think you might be having other problems.


I too am running a relatively new installation of W7-64 with 4.1.5 and I have no problems with Forrest running on. My problem with Forrest is that I want him to be visible all the time and if I have the 'hide icons' option enabled he will not stay visible long. IE if I set his icon to always be visible after a short time it goes back to being hidden. As if Windows forgets because he comes and goes. The I have some older versions of MEP running on old W2k systems which sometimes appear to get the stuck icon. The other time I always see Forrest stuck is when I remote to another system with Remote Desktop, disconnect, a macro runs, then I reconnect. He will always get stuck on then and I simply terminate MEP from its icon and re-launch. For one client I actually created a macro that restarts MEP. But on my system it works fine.


The fact that process Explorer and Task Manager are crashing is indicative that you have some other problem as that is not normal either. If I had to TS your system I would not start with MEP.


FYI "Forrest" is named for the movie "Forrest Gump" for the running references therein. Also the icon is a pretty simple character, just like Forrest Gump;-)

Link to comment
Share on other sites

FYI "Forrest" is named for the movie "Forrest Gump" for the running references therein.

I thought so. Always makes me cry that movie.


I have some troubles understanding your post. I guess i have been absent to this/english forums too long! ;-)


IE: What means to TS a system? Are there any options in the MEX Preferences or elsewhere (hide icons) i should try to compare our physical similar systems? What keys for pausing, aborting macros do you use?


Thank You


Link to comment
Share on other sites

Troubleshoot and Pause


TS = Troubleshoot. That is find your problem. My point was that if your system has other scary problems like Task Manager or Process Explorer crashing I would not look to MEP as the problem but rather a symptom.


Beware that some of the new rogue antivirus and other types of malware that will actively close things like Task Manager in order to prevent you from eradicating it. IOW these symptoms are often the self preservation behavior of a virus or unwanted program. I've worked on 8 systems in recent memory with rogue AV and many start with stories like this. And don’t trust your anti-virus software if it tells you all is well. On 3 of the systems Norton was reporting that it was up to date and all scans would find no viruses. But when I take the drive out and install it in my mule system and scan I find tons of viruses. These new apps and viruses have become very adept at disabling the AV in such a way that it appears to be running. If you're infiltrating a fortification and kill the sentry you don't just let him lie there, you prop him up so he looks like he's still at his post;-)


I can't think of any different setting to try on your system tray icon.


I don't like the default hotkeys for pause and abort. On US keyboards there is a key in the very upper right Pause/Break. Break is CTRL+Pause. Back when I programmed in Basic, Pascal and others this was the key for pausing or aborting the run. Still works for batch files and such these days. So it was natural for me to redefine the MEP default to use these instead. Easy to find and reach without looking and intuitive to remember. At least for me.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...