Jump to content
Macro Express Forums

Windows 7 Screensaver and Macro Express


hurricane51
 Share

Recommended Posts

I've searched though the threads about Macro Express and screensavers, and it seems the most common problem is screensavers preventing macros from executing. I have the opposite problem: if Macro Express is running my screensavers won't activate.

 

Windows 7, Gigabyte GA-H55M-USB3 motherboard, Intel i5-750 CPU. I have no problem on my older system, also running Windows 7. Macro Express version is 3.7.4.1

 

The only macros in my mex file are keystrokes assigned to hot keys, but even if I disable the macros it won't help. As soon as I terminate Macro Express everything works normally.

Link to comment
Share on other sites

... if Macro Express is running my screensavers won't activate.

 

From the Macro Express Knowledgebase: http://www.macros.com/kb.htm

 

Many scheduled macros do not work properly when the screen saver or power management features have been activated. To prevent problems, by default, Macro Express disables your screen saver or power management features if you have a Scheduled macro in your macro file.

 

In most cases you should be able to get a Scheduled macro to work properly with the screen saver or power management features enabled by modifiying the macro. For example, you may need to send a keystroke and then delay to allow your desktop to be restored.

 

To enable your screen saver or power management features when using a Scheduled macro, load the Macro Express Editor and click on Options | Preferences | Scheduler. Uncheck the box next to "Disable Screen Saver when using Scheduled Macros".

Link to comment
Share on other sites

From the Macro Express Knowledgebase: http://www.macros.com/kb.htm

 

Many scheduled macros do not work properly when the screen saver or power management features have been activated. To prevent problems, by default, Macro Express disables your screen saver or power management features if you have a Scheduled macro in your macro file.

 

In most cases you should be able to get a Scheduled macro to work properly with the screen saver or power management features enabled by modifiying the macro. For example, you may need to send a keystroke and then delay to allow your desktop to be restored.

 

To enable your screen saver or power management features when using a Scheduled macro, load the Macro Express Editor and click on Options | Preferences | Scheduler. Uncheck the box next to "Disable Screen Saver when using Scheduled Macros".

From my initial inquiry...

 

"The only macros in my mex file are keystrokes assigned to hot keys, but even if I disable the macros it won't help."

 

So I don't have any scheduled macros and even if I disable all the macros the screensaver still refuses to run. The only thing that enables my screensavers to kick in is when I suspend or terminate Macro Express. I've since upgraded to the latest version but things remain the same.

Link to comment
Share on other sites

From the Macro Express Knowledgebase: http://www.macros.com/kb.htm

 

Many scheduled macros do not work properly when the screen saver or power management features have been activated. To prevent problems, by default, Macro Express disables your screen saver or power management features if you have a Scheduled macro in your macro file.

 

In most cases you should be able to get a Scheduled macro to work properly with the screen saver or power management features enabled by modifiying the macro. For example, you may need to send a keystroke and then delay to allow your desktop to be restored.

 

To enable your screen saver or power management features when using a Scheduled macro, load the Macro Express Editor and click on Options | Preferences | Scheduler. Uncheck the box next to "Disable Screen Saver when using Scheduled Macros".

OK, I think I've found the culprit. Kaspersky Internet Security (2010) was identifying Macro Express as a suspicious key-logger. It didn't prevent it from working but apparently it prevented the screensaver from running, which put a twist into troubleshooting it. I'll be checking to see how effective my fix was over the next couple of days, but in testing the screensaver seems ok.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...