Jump to content
Macro Express Forums

Hot Key problem


rberq
 Share

Recommended Posts

I have a new PC running Win XP pro. It has a USB keyboard as opposed to PS/2 on my old PC. Windows and all applications are essentially identical to the old PC. The new PC is a different brand (Lenovo), and faster than the old.

 

Intermittently, macros triggered via hot key do not run. For example, Keypad-asterisk key runs a macro that simply types Win+M to minimize all windows. It will work once, then won't work for five minutes or so, then it will work once again, and so on. Same thing with another macro triggered by Ctrl-Alt-m -- it might work once, then not again for several minutes.

 

Also I pressed Ctrl-F1 to set the hot key for a new macro, and it showed up in Macro Express as if I had pressed Ctrl-Win-F1.

 

Ideas, anyone? Are scan codes sent from a USB keyboard different from a PS/2 keyboard? Is there some Windows setting I need to change?

Link to comment
Share on other sites

I and many others have been using a USB keyboard for some time without trouble. I've never heard of any setting in Windows to change anything for USB vs PS/2 connections. Is possible that your firewall/anti-malware software is blocking something or has not been trained to accept Macro Express? I would suspect something else on your new computer, not the type of keyboard.

 

Make sure you are using the latest version. The security patches Microsoft keeps applying can cause older versions of Macro Express to stop working properly.

 

If you send an email to our support people, they may have some other ideas.

Edited by kevin
Link to comment
Share on other sites

I think I have solved it. Through a macro (or otherwise????) the Win key apparently was "pressed" but not released. Once that was cleared up, all is right with the world once again. My old antique programmable keyboard didn't even have a Win key, so I never had to cope with it before....

 

Edit: I had a macro typing <WIND> l <WINU> to lock Windows. That's what was leaving the Win key depressed. I changed it to <WIN> l and it is OK now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...