Jump to content
Macro Express Forums

Comment puzzle


Recommended Posts

For the last few weeks I've been trying to improve the readability of my scripts by including a generous number of empty comments, separating appropriate groups of code. I've noticed that a minor proportion of them end up not quite empty. Instead they contain what looks at first like a single red minus sign '-'. Yet if I open such a comment, it appears truly empty! The cursor is in the home position, and deleting or backspacing doesn't remove the mystery red symbol.

 

But if I type in say 'abcxyz' then the result looks like the following.

 

MEProCommentPuzzle.jpg

 

This looks like an overscore has somehow 'leaked' into the comment.

 

Also note that, unlike a normal comment, it is not in bold, but in italics. I've long-wanted the facility to add formating to comments, just like a TBD - maybe this is a wormhole route towards that! ;)

 

As I suspect it has a bearing, I should add that I'm adding many of my comments these days using a macro. By r-clicking the Comment tool, a new empty comment is added below the selected line (or above, if the selected line is the very top one). For the curious, its design, based on help from Alan, was discussed in this thread.

 

Needless to say, it won't deliver the mystery symbols on demand; I've just added a hundred or so successive comments this way, and every one was truly empty. So some other combination of operations is triggering the spurious result. Who knows, it might even be a clue to the 'performance' issue!

 

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

You may have inadvertently executed the keystroke CTRL+N which disables a command. If you are not familiar with this feature I highly recommend you play with it. I find it an invaluable tool in developing and troubleshooting macros.

Link to comment
Share on other sites

You may have inadvertently executed the keystroke CTRL+N which disables a command. If you are not familiar with this feature I highly recommend you play with it. I find it an invaluable tool in developing and troubleshooting macros.

 

Thanks both. It must be as you suggested, the accidental application of a disable command. I use that a lot (via the icon, although I'll now use the faster KB shortcut). But I must admit I'd never have thought of applying it to an empty comment.

 

There's no explicit Ctl+n being typed in my comment-adding macro, and it has no mouse clicks, so I'll have to look elsewhere to pin down the precise source. One thought is a Ctl+n or mouse click in some other macro on a screen location corresponding to the Disable icon, somehow getting applied in the Script Editor instead of its intended target.

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...