Jump to content
Macro Express Forums

Console capture causes macro to freeze


Recommended Posts

I have macros on an SBS 2003 Server which stopped functioning a week or two ago, possibly after a system update. The macros contain an External Script or a Program Launch command which capture the output to a variable. The macro freezes at this command and will go no further. Command line Executable will still appear in the process list. Uncheck the console capture and the macro executes normally. The same macros work fine on other machines including a Windows Server 2003 Standard box.

 

ISS provided very in depth assistance but it appears the problem is with the server, not MEP. Has anyone experienced this or does anyone have any idea how I can fix it?

Link to comment
Share on other sites

It is now inexplicably working again. I did a test run with F5 and it simply worked. Doubt that had anything to do with it but who knows. More likely the things tried with ISS changed something. But I'm not going to look a gift horse in the mouth. At least this post will exist in case anyone in the future has such a problem.

Link to comment
Share on other sites

Can you see the console window at all? I'm guessing the external program encountered some problem and was prompting for input.

 

If the console window stays on your screen long enough, you can just manually capture the text within, as a fail-safe.

 

To do so, right-click anywhere on the title bar or within the window. Then navigate to "Select All" by sending arrow keys and Enter (The exact sequence varies with Windows versions). Once all the text is selected (wait about 60 ms), send Enter again and the text will be copied to the clipboard.

 

I have macros on an SBS 2003 Server which stopped functioning a week or two ago, possibly after a system update. The macros contain an External Script or a Program Launch command which capture the output to a variable. The macro freezes at this command and will go no further. Command line Executable will still appear in the process list. Uncheck the console capture and the macro executes normally. The same macros work fine on other machines including a Windows Server 2003 Standard box.

 

ISS provided very in depth assistance but it appears the problem is with the server, not MEP. Has anyone experienced this or does anyone have any idea how I can fix it?

Link to comment
Share on other sites

I know all that, thanks. In this case it was for any external program or script command. IE anything that used the feature to capture the console output. And these are all fully automated invisible scripts. But thanks for the input. I'm always weary these things can come back. In fact this one is specifically designed to track a problem with VSS that comes and goes!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...