Jump to content
Macro Express Forums

Delay pausing all macros


bakadoodle
 Share

Recommended Posts

Hello, I was hoping someone might be able to help me.

 

I've created 2 floating menus, each with multiple macro buttons. One of my macros needs to run on a 'repeat until (variable condition)' and delay for 40 seconds before the loop starts again. While in this delay state, none of the other macros function. This includes the macro I would use to update the repeat variable.

 

My question is; Is there a way to preform an unmanaged delay/wait/pause that doesn't put all of macro express on hold.

 

I've considered writing a timer loop using the 'variable set integer' - set integer from seconds/minutes/hours but that seems a cpu cycle intensive way to do something fairly simple like putting one macro on hold without putting them all on hold.

 

I may be missing something obvious,

Help would be much appreciated,

Thanks.

Link to comment
Share on other sites

Remove the REPEAT and the DELAY from the macro, so it just does its stuff once each time it runs, and then exits (MACRO RETURN). Using the Properties tab of the scripting editor, set it to run once every 40 seconds.

 

Change the second macro -- the one that currently sets the run/don't run variable -- to enable/disable the first macro (MACRO ENABLE or MACRO DISABLE). The variable used now will not be needed at all. During any period when the first macro is enabled, it will be run once every 40 seconds by the scheduler. During the 40-second intervals between runs, other macros will be free to run.

 

P.S. Use Options | Preferences | Scheduler from the ME menu bar, to set the Timer Interval to 1 second -- or higher if you aren't too concerned about the 40-second interval being quite so precise.

Link to comment
Share on other sites

Thank you rberq!

 

Thanks for the reply and the info. I have done as you suggested and it works. Unfortunately there is now a new problem.

As I mentioned, these macros are (no activation) button types in a floating menu. What happens now is that each time I enable or disable the scheduled macro, the floating menu disappears.

It is important to my purpose for these floating menus to not only stay up, but also stay "on top" of whatever window I am in.

 

Any more help would again be most appreciated.

Thanks for your time.

 

Nevermind. I set the 'active' property on the floating menu and it seems to have fixed it. :)

Loving ME right now :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...