Jump to content
Macro Express Forums

Long url doesn't work win MEP

Recommended Posts

In MEP, Commands > Internet > Website

I tried this;




It works fine.






This doesn't work. MEP simply doesn't do anything and I had to close MEP and restart it.


Is there any limit to the length of url in MEP? If so, how can I make the long url work well in MEP?


I use MEP to do this work and limiting the length of url is frustrating me.

Any help appreciated.

Link to comment
Share on other sites

Hi Koon, and welcome to the forum.


My instinct was that I expect there is a limit. Possibly 256 as a wild guess, given that your first is 240 and your second 424.


But not so. On testing, the latter worked OK here. Did you use the correct protocol https? Here's my single command macro:


Web Site, "https://soffice.11st.co.kr/Login.page?returnURL=%2Fbrowsing%2FmallDispDetail.tmall%3FobjApplySeqNo%3D37171111%26objApplySeqNo%3D37171112%26objApplySeqNo%3D37171113%26objApplySeqNo%3D37171114%26objApplySeqNo%3D37171115%26objApplySeqNo%3D37171116%26adcentreFlag%3DY%26adcentreFlag%3DY%26adcentreFlag%3DY%26adcentreFlag%3DY%26adcentreFlag%3DY%26adcentreFlag%3DY%26advrtItemClfCd%3D01%26method%3DreadDispApplyInfoByChangeRqstamt", using Default Web Browser


And here's the code:

<WEB SITE URL="https://soffice.11st.co.kr/Login.page?returnURL=%2Fbrowsing%2FmallDispDetail.tmall%3FobjApplySeqNo%3D37171111%26objApplySeqNo%3D37171112%26objApplySeqNo%3D37171113%26objApplySeqNo%3D37171114%26objApplySeqNo%3D37171115%26objApplySeqNo%3D37171116%26adcentreFlag%3DY%26adcentreFlag%3DY%26adcentreFlag%3DY%26adcentreFlag%3DY%26adcentreFlag%3DY%26adcentreFlag%3DY%26advrtItemClfCd%3D01%26method%3DreadDispApplyInfoByChangeRqstamt" Wait="FALSE" Default_Browser="TRUE" _IGNORE="0x000C"/>



Terry, East Grinstead, UK

Link to comment
Share on other sites

Thanks for your answer.

I didn't know what's wrong and so I thought it must be url limitation that could be cause.

I found that I should click 'running man' icon in tray to terminate the process when encountering some kind of errors.

Long url worked. It seems my newbie mistake.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...