Jump to content
Macro Express Forums

Lock Workstation


Recommended Posts

When I have a remote session active (I use Remote Administrator, www.famatech.com) and press Win-L to lock the remote workstation, MEP locks the local workstation at the same time. But this only occurs under Windows 7. Under XP, MEP catches the keystroke and passes it onto the remote session as expected (e.g. the local workstation does not act on the "lock" keystroke).

 

I've tried "Restore Keyboard and Mouse Hooks", but the local PC is still acting on the Win-L keystroke.

 

Is there way under Win 7 to make sure that MEP gets the keys like XP does?

Link to comment
Share on other sites

When I have a remote session active (I use Remote Administrator, www.famatech.com) and press Win-L to lock the remote workstation, MEP locks the local workstation at the same time. But this only occurs under Windows 7. Under XP, MEP catches the keystroke and passes it onto the remote session as expected (e.g. the local workstation does not act on the "lock" keystroke).

 

I've tried "Restore Keyboard and Mouse Hooks", but the local PC is still acting on the Win-L keystroke.

DIsable/Enable Lock Workstation

Link to comment
Share on other sites

Great idea, Paul! But I don't really want to disable it entirely. I just want the Win-L keystroke to get passed to my remote session when it has focus.

 

I think the problem is that, even when the remote session has focus, Win 7 is acting on the Win-L keystroke itself. That behavior is different than XP.

 

In Win 7, the OS seems to pass all other system hotkeys to the remote session when it has focus (e.g. Win-E, Win-R etc). But Win-L locks the local workstation whether the remote session has focus or not. :(

 

I initially thought your idea would work if I disabled the Lock Workstation function and then wrote a macro to run the Lock Workstation command and use Win-L to activate it. But when I disable the lock capability using the registry, it really turns it off at a fundamental level so the capability is completely unavailable.

 

Maybe I can figure out how to remap the Windows 7 Win-L to something else so I can make it available in a macro. But even that might still cause the local workstation to lock instead off the workstation on the remote session.

 

Thanks for the suggestion though.

Link to comment
Share on other sites

I think the problem is that, even when the remote session has focus, Win 7 is acting on the Win-L keystroke itself. That behavior is different than XP.

I'm surprised to read this. For a while I was using RDP extensively inder XP since my development machine was remote, and pressing Win-L always locked the local workstation (and I don't know whether the remote one was locked or not).

Link to comment
Share on other sites

I'm surprised to read this. For a while I was using RDP extensively inder XP since my development machine was remote, and pressing Win-L always locked the local workstation (and I don't know whether the remote one was locked or not).

 

Yes, it works that way when using RDP. But when using Remote Administrator (Famatech.com), it is different. I guess I thought it had something to do with Macro Express, but apparently the behavior you see nominally using RDP w/ both XP and Win 7 is "normal".

 

Guess I'm outta luck.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...