Jump to content
Macro Express Forums
Lars_Sandberg

Exact Windows Title Activation & Shortkeys

Recommended Posts

Hi, in an application, I want ME 3.501 to activate automatically when a window only with the

exact title: "save" appears. For now ME activates on any window, where the word "save" is

included in the title bar. Is there any way to do that for an exact match?

At least during the scope option, my macro only runs when an specific application is on top.

 

 

Another thing, after I began to use ME 3.501, occasionally my shortkeys won't react (no other

macro is running), then maybe 1 hour later, they work fine again. I use Win XP SP1a

 

 

--

Best regards

 

Lars

Share this post


Link to post
Share on other sites

It is really annoying when almost all window manipulation commands (activate, hide, close etc) do not allow "Exact Window Title Only". The situations, where allowing partial window names is a real nuisance, are not so very infrequent.

 

Makers of Macro Express: is there some good workaround, or can we expect to see this "Exact Window Title Only'-option in later versions of ME?

Share this post


Link to post
Share on other sites

I save the window title to variable, and then use an "If variable = "SAVE". I guess I could probably use an "If control focused" too.. haven't tried that yet though.

 

Doreen

Share this post


Link to post
Share on other sites

Thanks! This helps in many situations. Can you say which command saves the unknown active window's title to variable? - I thought it is easy to find, but after half an hour I now gave up. Do I have to know the name of window beforehand?

Share this post


Link to post
Share on other sites
I save the window title to variable, and then use an "If variable = "SAVE"

Hi Doreen, thanks for the tip, it's a very good idea.

 

By the way, if anyone have a clue of the shortkey bug, i'm all ears.

 

regards Lars

Share this post


Link to post
Share on other sites
try the Tools / Restore Keyboard Hooks command ?

Hi, in options I have tagged: "Auto Restore Keyboard Hooks" on plus, I tried the menu you also suggested, and in some cases (as far as I remember) ME just won't accept my shortkeys, and then for example 10 minutes after they work normally again.

 

regards Lars

Share this post


Link to post
Share on other sites

Hi, after I encountered the bug yesterday, I can comfirm that: Tools / Restore Keyboard Hooks" doesn't help. For a period of time shortkeys are simply dead, both in ME 3.4b and 3.501

 

regards Lars

Share this post


Link to post
Share on other sites

Hello Lars!

 

Could there be another application running that is not Macro Express that may be intercepting the keystrokes? Maybe something that runs in the background? Does this happen on another workstation? Is the problem centered around particular ShortKeys or any ShortKey? When the ShortKeys are knocked out, do HotKeys still work?

Share this post


Link to post
Share on other sites

Hi Joe. No i'm typing in the topwindow (MS Access database, Outlook etc.). My hotkeys works normally, also when my shortkeys are dead.

I have seen this on 2 computers, that means my own with Win 2000 Pro & ME 3.4b and on my work, Win XP & ME 3.501.

Some times, but not always, the activation of a hotkey wakes the shortkeys to work again.

 

regards Lars

Share this post


Link to post
Share on other sites
Hi Joe. No i'm typing in the topwindow (MS Access database, Outlook etc.). My hotkeys works normally, also when my shortkeys are dead.

I have seen this on 2 computers, that means my own with Win 2000 Pro & ME 3.4b and on my work, Win XP & ME 3.501.

Some times, but not always, the activation of a hotkey wakes the shortkeys to work again.

 

regards Lars

I also have the same problem of sporadically inactive shortkeys. My shortkeys are activated without prefix or suffix requirements, and I use Win2K with version 3.5c ME.

 

I will run into issues where no shortkeys will function (often for several minutes) and then suddenly start working again. No combination of opening/saving macros, restoring keybd hooks manually, etc. seems to do any good. This will happen in Wordpad, PowerTerm, other applications. (And yes, I did check the ME icon in the tray for the running man to confirm no macro is already running and blocking the shortkey activation.)

:unsure:

Share this post


Link to post
Share on other sites

I have the same issue with ME 3.5c and W2K. Restore Keyboard Hooks doesn't resolve the problem. Restarting ME fixes the issue but sometimes it reoccurs rather quickly while other times it may not happen until the next day. I thought maybe it was something wrong with m computer but seems as if others are having the same problem. I never experienced this with previouse versions.

Share this post


Link to post
Share on other sites

Have you reported these ShortKey activation problems? Use the "Options | Configure Bug Reporter | Report a Bug" feature.

Share this post


Link to post
Share on other sites

Sometimes, the shortkeys buffer can get "clogged" up. Macro Express does have a way to clean it up by simply pressing the control key a couple of times. Does that work at all for you?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...