Jump to content
Macro Express Forums

Using "Program Launch" to launch application shortcuts

Recommended Posts

Hi there, folks,


I have a macro that opens applications using the "Program Launch" command, and it works fine.


I took one of said applications and made a shortcut for it, with the same name.


I opened the Program Launch command window, rebrowsed to the location, and selected the shortcut. It changed the name to "Notepad.exe.lnk". When I run the macro, I get the following error:


The following error was encountered:


The program could not be launched "[File Path]\Notepad.exe.lnk"


I know the file is there, and I know the shortcut and application both work. I can run the macro pointing at the application, but not the shortcut.


Can macro express not launch shortcuts?



Link to comment
Share on other sites

MEP can launch LNK (Link) files. I just created a link to one of my programs to be certain and it worked fine. Make sure that's the actual file name. Also make sure you didn't include the quote marks. Other than that I would suggest posting your raw code here so I could test it myself.

Link to comment
Share on other sites

Right. If he created a shortcut manually it would be like "C:\Users\Cory.BD\Desktop\Notepad.exe - Shortcut.lnk". I suppose he coudl have deleted the visible " - Shortcut" and got that as a result.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...