Jump to content
Macro Express Forums

Macro Express Pro on Parallels

Recommended Posts

Hi there,


I`ve been using Macro Express Pro for my work on a daily basis.

After my Laptop died I´ve decided to use a Mac with Parallels for the stuff I have to do in Windows.


Unfortunately I can´t get it to work since all actions that are related to coordinates do not work (it looks like the mouse is not moving at all).

Does anyone have experience with parallels and how did you get it to work?


Thank you!



Link to comment
Share on other sites

  • 6 years later...

I am using Macro Express 5

Parallels on iMac 2019

MacOS Monterey

Windows 10


The program I am trying to use with Macro Express with is Lightroom Classic V12.1


What I have discovered so far.

I create macros by starting with "capture macro".

I must use "Begin capture in window "Last Active Window"" otherwise I never see the next screen "Start Capture". 


Capture process goes fine.


Here is the big deal, and the thing that was really causing me problems. I was using an alt/option key combination to activate the macro (specifically alt-3) . If I did that, I had to hold the activation key (alt-3) down for at least 1/2 to 3/4 of a second for the macro to activate.  If I pressed and released quickly, all I heard was a beep.  No macro activity occurred.


Lesson learned. Don't use alt/option combination to activate a macro, at least when running on Lightroom Classic.

For what it's worth, I now use ; (semicolon) as my macro activation key, in Lightroom, in the develop module.


Hope this info helps somebody. 




Link to comment
Share on other sites

Not having a Mac I'm probably not going to be much help here, but I will say a few things. 

I assume this is a VM. I know in other VM and remote Desktop kind of stuff when the machine thinks it's not connected events stop. So for instance if it's minimized all the control activations will not work. Perhaps that's your issue. 

Another thing is that with RD one should connect to the console session, and not the remote session. You can search online to find out how to do that. 

Finally I avoid using the mouse in my macros at all cost. Sometimes it's essential, but the majority of the times I've helped user who think that can not do things with a keyboard, I find a way they can. Mouse seems to be the easy solution, but they just breed problems later. 

Link to comment
Share on other sites

  • 4 weeks later...

I have a new MacBook Pro M1 (Apple Silicone) running Parallels with Windows 11 Home 22H2 64bit ARM based. Yes, this is a VM, not an expert at all though. Like most things, I landed in this new configuration by accident.

I've run a few macros now without issues but, I just ran into the issue of the mouse move not working at all. I usually try to stay away from the mouse as well, but I do have one macro that does a mouse move and color check. I had to eliminate that part of the macro. I have only run a handful of macros so far, but the mouse move issue has been the only issue that I noticed so far. Glad to see other people are running similar configurations.

Previously I ran 2012 MacBook Air with Bootcamp and Windows 10. It ran Macro Express really well with no issues. From what I understand, Bootcamp doesn't work with the newer Apple chips and Windows. It required an ARM based windows version, whatever that is.

Link to comment
Share on other sites

New revelation about the mouse move issue. I have a macro that clicks on the green running man to abort a macro. I noticed this still works, but the mouse pointer on the screen that I can see (on the screen) does not move. It operates in ghost mode, spooky! So, I suspect the pointer (mouse move) still actually moves, it is just happening in an alternate universe.

Link to comment
Share on other sites

  • 4 weeks later...

Pretty much all of my macros seem to work without adjustments. I don't use the recorder so I'm not sure how that would work. The mouse pointer move is a little bit of an issue. It can still move and click things it just doesn't move the visible on screen pointer. Here is one possible fix. Check here, Parallels knowledge base: https://kb.parallels.com/122903 I have not tried it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...