Jump to content
Macro Express Forums

Adobe Acrobat X Pro - Cannot get macro to run


Recommended Posts

I cannot get a macro to run in Adobe Acrobat X Pro. Trying to stamp and sign a document.

 

The macro was running in the past with Adobe Acrobat X Pro but it stopped working.

 

I have disabled all the lines in the macro in attempt to debug, but nothing works.

 

I want to select the menu option View-Comment-Annotations

In Adobe, I can manually type Alt-v-m-a.

 

In Macro Express Pro I am doing this:

1. Textype <Alt>

2. Textype v

3. Textype m

4. Textype a

(I disabled the remaining lines until I can get this much to work again)

 

I activate the macro with Alt-S

 

When I run the 4 lines above, Acrobat wants to insert a "Article Box". I have no Idea why.

 

Is anyone using Macro Express with Adobe Acrobat Pro?

Thanks

Bill

 

Link to comment
Share on other sites

I don't have any good ideas. I'm still using 9! Alt+v is view and m toggles the menu bar off. Crap, now I can't get it to reappear!

 

Maybe slow it down. Add some delays, if only for testing. Especially after the Alt+v.

 

BTW if you have high volume requirements there are other ways to automate things like this in Acrobat. But MEP is great for small volume.

 

Now I got to fix my Acrobat...

Link to comment
Share on other sites

You might also make sure the window is focused. Other than that, you should be able to see what is happening if you run it slowly. The only other thing I could think of is if the modifier key is getting stuck.

 

Another thought is to make sure your keystroke combinations are not conflicting with any existing hotkeys. Or that your keystrokes aren't causing another macro to execute.

 

You might try Ctrl+8. According to this page that should bring up the comments directly. I always try to use existing hotkeys and avoid the menu bar.

 

There are some command line options and an API. Or at least there was. Years ago I created some external scripts in MEP to extract pages and many other things in Acrobat. I've heard there are some better APIs now. You might also look for Acrobat utilities. EG I used to use one called Split/Merge.

Link to comment
Share on other sites

You start your macro with Alt-S. Are you sure the macro is actually running? Or maybe the Alt-S is being captured by Acrobat and doing something within Acrobat? I had that problem with a different version of Acrobat; macro was fine but the hot key to start it was ignored when Acrobat was running.

 

Put a Text Box Display as the very first line of your macro to see if the macro starts up and displays it.

Link to comment
Share on other sites

Here are some ideas I had:

1. See if using <ALTD> and <ALTU> instead of <ALT> works better.

2. Try slowing down the typing a bit. Maybe Acrobat or your computer are responding a little slowly.

Keystroke Speed: 1000 milliseconds
Text Type (Simulate Keystrokes): <ALTD>v<ALTU>ma
Keystroke Speed: 1 milliseconds

(If this helps then adjust the 1000 milliseconds to something more reasonable that still works.)

 

3. To determine whether or not a macro is being activated you can, as rberg suggested, put a Text Box Display as the first line in the macro. Another idea is to put a Sound File command in the first line of the macro. Or, with v 4.7.0.1 and later you can use the "Play a sound when a macro runs" option found in the Preferences under Playback, Miscellaneous. This option will play a sound every time a macro is activated so you will want to turn it off after fixing your macro.

4. Try running Macro Express Pro as Administrator. Some programs do not allow macros to run unless Macro Express is running with Admin privileges.

5. Try turning Protected Mode off in Adobe Acrobat Reader:

  • Open Adobe Acrobat Reader
  • Click Edit, Preferences
  • For Adobe Acrobat Reader DC or XI click Security (Enhanced)
  • For Adobe Acrobat Reader X click General
  • Click to uncheck the "Enable Protected mode at startup" setting
  • Click the OK button to save
  • Restart Adobe Acrobat Reader

Please let us know what, if anything, helped.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...