Jump to content
Macro Express Forums

Strange Administrator Behaviour


Recommended Posts

I followed the instruction posted in another thread here :- https://www.macros.com/faq/1.92.html for setting Macro Express up to run as an Administrator.

Now I've noticed a simple one line macro desktop shortcut doesn't work.

The only line in the macro is:-

Hibernate

I tried sending it to a log file and it doesn't record anything.

If I run the same macro from Macro Explorer, it works every time.

Oddly, if I right click the desktop shortcut and 'Run as Administrator' it DOES work, but not when double clicking or right clicking and selecting Open.

Can someone else see if they are seeing this behaviour please before I submit it to support?

Link to comment
Share on other sites

Try using MeProc.exe. I don't recommend your method of using shortcuts but it should work if the shortcut uses MeProc.exe instead of MacExp.exe. MeProc looks to see is MEP is running already and hands the command over to it if found. I think it should then work since MEP is running as an administrator at that point. Otherwise another instance of MEP is launched with normal permission. If that doesn't work please post the command and parameters of your shortcut. Also I think one can set a shortcut for "Run as Administrator". 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...