Jump to content
Macro Express Forums

Another Odd Thing


IainKewley
 Share

Recommended Posts

I have a very simple macro that opens a text file based on a server. It works just fine. I have copied it to a new macro using copy and paste (to add more instructions) and it no longer works. Specificallly, the text that the macro uses to open the file changes. So the

Text type shows

"\\emis8803a\practice\reports\x-patient-id"

 

This comes out in the open file dialog as "||EMIS**)"|PRACTICE|REPORTS|X_PATIENT_ID>RTF"

 

I thought it had to have something to do with caps lock - but inserting Caps Off doesn't change it & as I say, these are two identical macros (apart from their name and some disabled commands in the new one)

 

Any ideas?

Link to comment
Share on other sites

It does appear that the keyboard is shifted. This does not look like a Caps Lock issue. If it were, the numbers would not be altered. It looks more like a Shift Lock (if there is such a thing). Could there be a Shift Lock setting in the application you are using?

 

I recommend that you check for a Shift Down that is missing a Shift Up.

 

You didn't describe your computer system or what you are using to activate this macro. We have had a report of a similar problem from a company using Macro Express in a Citrix/Windows Terminal Services environment. If they assigned their macro a hotkey of Ctrl+b then the control key was down inside their macro. What was happening is that the macro started sending keystrokes before Citrix/WTS had received the Ctrl key up message that is sent when the user released the Ctrl and B keys. If I recall correctly they may have also had a similar problem with Shift+b.

 

If this is the cause, Here are some possible solutions:

  • You may have success adding a small delay at the top of the macro.
  • You may be able to add a Shift Up command at the top of the macro. The syntax checker may complain about a mismatched Shift command so you may need to do a Shift Down followed by a Shift Up.
  • If the problem is caused by a shifted hotkey, try reassigning the hotkey to something without a shift. You may need to avoid control as well.
  • Look for a setting in the application that deals with the shift key.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...