Jump to content
Macro Express Forums
terrypin

MEP toolbar problem

Recommended Posts

No matter what order I open them or where I drag them, I cannot get my toolbars back to their normal positions. Restarting MEP didn't help.

 

ToolbarProblem-1.jpg

Share this post


Link to post
Share on other sites

How about running as admin, moving them, and closing MEP?

Share this post


Link to post
Share on other sites

Thanks for the prompt reply Cory. I didn't try that but persisted with every combination of View > Main/Edit/Debug toolbar and every drag sequence and location, slow and fast - and after another half hour or so I struck lucky.

I don't relish going through all that frustration if it happens again. So I've been trying to find where the toolbar settings are stored. Couldn't find an INI file. I've tentatively exportedt the largest registry key of Insight Software Solutions I could find, even though I couldn't see any obvious reference within it to Script Editor toolbar locations.

With a few of my other apps there's a KB shortcut that restores the UI to its defaults, but it appears MEP does not have one.

Share this post


Link to post
Share on other sites
13 hours ago, terrypin said:
Quote

 

I don't relish going through all that frustration if it happens again. So I've been trying to find where the toolbar settings are stored.

HKCU\Software\Insight Software Solutions\Macro Express 4\Toolbars\Editor

 

Share this post


Link to post
Share on other sites

Thanks Paul. I don't have that key on my PC but in that general section I found this strangely named 'temporary' key


Computer\HKEY_CURRENT_USER\Software\Insight Software Solutions\Macro Express 4\$Temp\Toolbars

Does that appear to contain similar content to the one you presumably have on your system please?

 

MEP-Registry-Toolabrs.jpg

Share this post


Link to post
Share on other sites

You might want to report the issue to Insight. I discovered some inconsistencies with the toolbars and menus in the latest release of MEP, which I reported. Insight worked with me on the problem, confirmed there was something amiss, and provided me with a workaround, which has worked ever since.

Share this post


Link to post
Share on other sites

I didn't follow everything you were doing in the registry but I had a thought. How about you export the entire key-set for MEP HKCU and HKLM to a .REG file, make a small change to the position, and export it again. Then do a file compare to see what changed. Or better yet, use Process Explorer to monitor for registry changes

Share this post


Link to post
Share on other sites

The toolbar settings are stored in the registry.  In previous versions of Macro Express Pro the toolbar settings were located here:

 HKCU\Software\Insight Software Solutions\Macro Express 4\Toolbars\Editor

However in later versions of Macro Express Pro the toolbar settings are located here:

HKCU\Software\Insight Software Solutions\Macro Express 4\$Temp\Toolbars

Other temporary values stored in the $Temp are the window sizes and positions (...\$Temp\Windows), things you have searched for in the Script Editor or Macro Explorer (...\$Temp\Search History), settings relating to the grids found in various dialogs, and the last path used when browsing for files from different dialogs (...\$Temp\Paths).

To restore Toolbars to their default positions right-click on the M icon in the Notification Area, click Tools, and then click Restore Toolbars. Similarly clicking M, Tools, and Restore Window Positions will reset the size and positions of a bunch of dialog windows. Whenever I do this I first close all the visible parts of Macro Express (Script Editor, Menu Builder, and Macro Explorer).

But, if I recall correctly the default location for the toolbars looks like the image you shared where the Save and Close toolbar is on a different line than the Test Run toolbar. It seems to me that after resetting the toolbars I always have to drag the Test Run toolbar up next to the other toolbars.

Share this post


Link to post
Share on other sites

Excellent, thanks, never saw that Restore Toolbars entry before! A Help search on either 'restore' or 'toolbars' delivers nothing about it.

In view of your last paragraph I've decided to resist the temptation to try it, in case it produces the result you recall! I have them the way I want right now, which I've always assumed is the default. If that ever gets corrupted again I'll then try either the built-in method, or by restoring the reg file I made based on my Sunday post. Or if someone comes up with a simple sequence of moves that's less complicated than solving the Rubik's Cube, I'll use that.

MEP-Toolabrs-Correct.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×