Jump to content
Macro Express Forums

Macros won't run from the command line

Recommended Posts

When I try running a macro from the command line absolutely nothing happens. No error message no results.

I've tried multiple macros, including one system macro. 


macexp.exe /A"Terminate Macro Express"

macexp.exe /ATerminate Macro Express

macexp.exe /A::C:\Users\Fulfillment\Documents\Insight Software\macex.mex?Test

Must be something simple I'm not doing?

Link to comment
Share on other sites

Are you in the folder where the Macro Express program files are installed?

cd "C:\Program Files (x86)\Macro Express Pro"
macexp.exe /ATerminate Macro Express

or include the full path

"C:\Program Files (x86)\Macro Express Pro\macexp.exe" /ATerminate Macro Express


Link to comment
Share on other sites

  • 4 months later...

Came across this thread today and would appreciate re-opening the discussion. I tried the same syntax options as Nathan - all in vain. If it ever did work, that no longer does so in Win 10 version 1903. Would welcome contradiction!


I think there's some ambiguity about the correct syntax. I interpret Help Command Line Parameters as meaning that to run a macro called 'Test Open Notepad' we should use the following in either the Run box or (with extra effort to change directory as Samrae says) at a Command Prompt:

"C:\Program Files (x86)\Macro Express Pro 6\Macexp.exe" /ATest Open Notepad


That fails here in both, as do variants of it. Does it work for others?


The only reliable way I've found to run a macro externally is to first export it with R-Click>Export>Export as Playable


For example, having done that, placing the following in the Run Box will open Notepad:

C:\Users\terry\Dropbox\MXE files\Test Open Notepad.mxe



Link to comment
Share on other sites

I just entered this at the "Run" prompt, and it worked:


C:\Program Files (x86)\Macro Express Pro 6\MeProc.exe /AOpen C drive in Windows Explorer


"Open C drive in Windows Explorer" is the nickname of a Global MEP macro.


I did NOT include the quote marks on the Run line.


I suggest double-checking that the nickname is unique. Macro Express doesn't care whether you have more than one script with the same nickname, but heaven only knows which one will execute if two or more scripts have the same nickname.

Link to comment
Share on other sites

I tested this on both Windows 7 and Windows 10 1903. I used a batch file instead of the Run dialog.


This does not work:

"C:\Program Files (x86)\Macro Express Pro 6\macexp.exe" /ATest Text Box Display

This does:

"C:\Program Files (x86)\Macro Express Pro 6\Meproc.exe" /ATest Text Box Display

The results were the same for Windows 7 and Windows 10.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...