Jump to content
Macro Express Forums
garlicnonions

ME3 does not see an executable file which windows explorer does

Recommended Posts

I am trying to launch snippingtool.exe in windows 7 using ME3 activate/launch program command. when I try to browse to and select the executable file "snippingtool.exe" in the C:\Windows\System32\ directory it doesn't appear...see attached file. Its there when i navigate to it using windows explorer...what's going on ?

 

Thanks, John

Capture.JPG

Share this post


Link to post
Share on other sites

I can reproduce the problem on my PC, which is running ME 3.9.0.1 and Windows 7.  But I don't know the solution.  If I type in the program name and checkmark the box "Bypass File Existence Check" in the Program Launch command, then the macro fails with "program not found" when I run the macro. 

ME 3.11.1.1 on Windows 10 behaves the same. 

 

Somewhere along the way, I believe Windows introduced some freaky cataloging/registering technique for executables, where they couldn't be run by the customary methods.  I never did understand it and still don't, and in fact I may have dreamed it but I don't think so.  Do a google search???

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...