Jump to content
Macro Express Forums

Recommended Posts

I have had to reinstall my operating system (Windows 10) due to some corruption. I am in the process of reinstalling all my bits and bobs.

 

I have a huge amount of macros for an application I run within DOSBox. For this, I have created an extensive menu structure. I invoke a main menu with a hotkey; from there, I can then select macros directly, or select submenus. This has always worked flawlessly.

 

Now, however, not so much. When I invoke the main menu with the hotkey, and then navigate around in the menu, for instance with arrow keys, or click on a submenu, some of them pop up for an instant, but then close immediately. The upshot is, I cannot select from those menus, because they don’t stay open.

 

I’ve looked around in Macro Express options, but I see nothing there that seems to help. Anybody have any idea what’s happening here???

 

Adding to this: my preferred "Menu Style" is "Windows Default." I find that if I change the style to "Nickname and Scope" (for instance), then the submenu works just fine: opens up and stays open for me to select from, either by keyboard or by mouse.

 

Is this a Windows issue I am not aware of?

Edited by MakaPakaTobyHannah
further details provided
Link to comment
Share on other sites

Answering my own post... I see that nobody posted a response, or suggestion - which clearly indicated that the issue was specific to my system, which I had suspected anyway. I thought that maybe upgrading to the most recent ME version might solve the problem. It didn’t. I wrote to tech support; they were unaware of an issue as well.

 

For anyone who might encounter this type of thing, this was the culprit in my case. I run three three monitors, and to maximize their usefulness I also run a utility called "Actual Window Manager" (which I love). On reinstalling my operating system and applications, Actual Window Manager installed default settings. I restored my preferences from a settings file I had backed up. But apparently, one crucial setting was not part of that backup. It is a mouse option that activates or deactivates a window on "mouse hover". When the mouse hovers over a window, it is activated. Conversely, if a mouse is moved off a window, it automatically becomes deactivated. I find that feature useless and annoying.

 

Anyway, it was checked, and this caused some ME menu to close instantly, as the mouse pointer was not on top of the menu. Feature turned off, problem solved.

Link to comment
Share on other sites

Good to know.  Thanks for the follow up.  I also recall that I had to stop using Actual Window Manager due to a similar problem in Chrome.  Maybe I'll reinstall, and try your suggested fix.  

Link to comment
Share on other sites

I have a similar large menu structure like yours, here in Win 10 Pro Version 1803 (OS Build 17134.766). But I've always used the Nickname and Scope setting by choice. Was there a particular advantage for you in using the Windows Default?

 

Three monitors: you must get plenty of good neck exercise! And have a larger desk then me 😉

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...