Jump to content
Macro Express Forums
Pete

Datafile.GetActMacros error

Recommended Posts

I have just upgraded from ME3 to Pro 6.1.3.1

Preferences are set to Log Unusual Events.

 

Every time the scheduler checks for Scheduled Macros (whatever frequency is set) I get the following event logged

 

13 February 2020 09:15:48:206: Datafile.GetActMacros error: Invalid argument to time encode
  fname: F:\xxxxx\xxxxx\xxxxxxx.mex

 

I doesn't seem to affect macro execution as far as I can tell, but it makes for a large log file, and means I have to have notifications of unusual events turned off.

 

Anyone come across this?

 

Thanks, Pete

 

 

 

Share this post


Link to post
Share on other sites

Report to ISS first.

 

Just a few thoughts off the top of my head

  1. What's the frequency?
  2. Are you synchronizing? (Preferences > File System> Network tab > Synchronize the macro file
  3. Are you backing up?
  4. Are you running MEP with elevated permissions? (AKA Run as Administrator)

Share this post


Link to post
Share on other sites

Maybe some sort of time zone issue?

 

If you could post a minimal scheduled macro that causes that behaviour we could try to reproduce.

 

FWIW I regularly use scheduled macros for important reminders. I've never changed the frequency from its default of 10 s, but I don't see that notification.

 

P.S: It's Valentine's day tomorrow!

 

Share this post


Link to post
Share on other sites

Thanks everyone,

Cory.

1. Frequency is 2 secs, but behaviour doesn't alter with any frequency.

2. Synchronising is on but deactivating it makes no difference.

3. Backing up when the Editor closes.

4. ME runs at startup.The account logged in is an administrator, but I am not specifically running ME as administrator.

 

terrypin

There is no macro running, it is logged every time the scheduler checks (every 2 seconds if that is the setting)

 

I will report to Insight.

 

 

Share this post


Link to post
Share on other sites

Maybe try closing all macro files and create a macro file without macros. Just a random idea. 

Edit: Try remove and reinstall.

Edited by Cory
Another thought

Share this post


Link to post
Share on other sites

Update.

It is restricted to one large macro file converted from ME3

The same file causes the same issue on 2 PCs

The problem does not occur when the offending file is closed.

The file has been sent to Insight for analysis.

Share this post


Link to post
Share on other sites

Solved.

The issue was investigated by Kevin at Insight:-

ME3 does not have an "Hour" option for scheduling a macro, but you could have a "minute" value of over 59. I had one ME3 macro with a value of 120 minutes, which after conversion, tripped up the ME6Pro scheduler. I changed the schedule to every 2 hours 0 Minutes and the problem was solved.

Insight will update the conversion routine to correct this.

 

Thanks Kevin.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...