Jump to content
Macro Express Forums

Recommended Posts

Hello dear forum friends. I have a problem with MEP 4.6.2.1 that I think is caused by myself.

In the past, a syntax check was carried out when saving or exiting a macro. It's gone now. How can I get it back?

Thankyou,

sokobana

Share this post


Link to post
Share on other sites

I duplicated this issue using Macro Express Pro 6. When the Syntax Error box is displayed and you click "Don't show this again", syntax checking is turned off and cannot be easily turned back on.

 

Syntax checking can be restored if you edit the registry and change

  HKEY_CURRENT_USER\Software\Insight Software Solutions\Macro Express 4\Editor\Check Syntax

 

to a value of 1.

 

I have reported this to Insight Software Solutions. There should be a better way to re-enable syntax checking.

Share this post


Link to post
Share on other sites

You could also restore syntax checking by running the MacDef.exe program in the c:\Program Files (x86)\Macro Express 4 folder. But, if you do that, all of your preferences will be reset to their default values.

  • Like 1

Share this post


Link to post
Share on other sites

Hello Samrae,

Thank you for your informations!
There are no entries for the program in my registry. I have now noticed that I am using the portable version. Is it because of it?
 

In the MacExp.ini file I found a [Editor] section with the entry
Check syntax = 1

 

Your Tip with MacDef.exe I haven't tried  yet.

 

Best regards,

sokobana

Share this post


Link to post
Share on other sites

Yes, if you are using the portable version the settings would be in an .INI file and not in the registry.

 

If the .INI file contains Check Syntax = 1 I would expect the syntax checking to work. To be sure, you could delete the line in the .INI file that contains Check Syntax to tell Macro Express to turn syntax checking back on.

 

Be sure that Macro Express is not running when you change the .INI file.

 

Share this post


Link to post
Share on other sites

That did not work.
But now I tried your tip with MacDef.exe.
Yippieh, now i have Syntax checking back again.

You were very helpful for me,
thankyou Samrae 😀

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...