Jump to content
Macro Express Forums

Alt-letter does not activate the initial-letter-underscored activity


Recommended Posts

Still trying to automate the Export of Active Desktop Calendar's data.

My macro now opens the drop-down that exposes the EXPORT option

but the coding for neither ALT-E nor for down-arrow-to-Export, works as required\expected.

The time delay has been tried from 1 to 5 seconds.

So how can I make either of those effective ?

ADC Export.JPG

Edited by Sebastian42
added extra information
Link to post
Share on other sites

Have you set up the forum's "Follow" option so you will be notified of activity on your threads?  There were several replies to your previous posting of this question.  See upper right on the page to "Follow". 

Link to post
Share on other sites

Why are you making so many different threads for the same topic?

I don't have your program, can you produce this problem in Notepad?

The one thing I see that looks wrong is the alternate function for e. I think it shoudl be just e. In Notepad if I want to open "Save As" I type Alt, f, then a. Note that it's not alt+f. and not alt-a. Once the menu is active, you don't use the alt key anymore. That's only in dialog boxes. 

Link to post
Share on other sites

As recommended elsewhere, please put macro samples in a codebox (see <> above) instead of posting an image.

 

When you have the macro do a Text Type <ALT>E what gets sent to the application is <ALT Down> <Shift Down> e <Shift Up> <ALT up>. What you need is:

Text Type (Simulate Keystrokes): <ALT>e

Sometimes that does not work reliably. This often works better:

Text Type (Simulate Keystrokes): <ALTD>e<ALTU>

 

Link to post
Share on other sites

To copy what you see in the Macro Script Editor, highlight the macro lines lines you want, right-click, and click "Copy Command Text". Then, in this forum, click the <> icon and type ctrl+v to paste. The result looks like this:

Text Type (Simulate Keystrokes): <ALT>e
Text Type (Simulate Keystrokes): <ALTD>e<ALTU>

To copy macro commands that someone can copy from this forum and paste into Macro Express, highlight the macro lines you want, right-click, and click "Copy". Then, again, in this forum, click the <> icon and type ctrl+v to paste. The result looks like this:

<TEXT TYPE Action="0" Text="<ALT>e"/>
<TEXT TYPE Action="0" Text="<ALTD>e<ALTU>"/>

Often when asking for help it is a good idea to post both. If you make it easy for forum members to understand and help you will get better answers. 🙂

Link to post
Share on other sites
2 hours ago, Samrae said:

Text Type (Simulate Keystrokes): <ALT>e

Sometimes that does not work reliably. This often works better:


Text Type (Simulate Keystrokes): <ALTD>e<ALTU>

 

Yes!  I was beginning to think I was the only one to have that problem!  Rather than gamble, I ALWAYS use the key-down / key-up sequence rather than rely on Macro Express to do it magically. 🙃

Link to post
Share on other sites
14 hours ago, rberq said:

Have you set up the forum's "Follow" option so you will be notified of activity on your threads?  There were several replies to your previous posting of this question.  See upper right on the page to "Follow". 

I have both clicked the follow option and also neglected to.

 

11 hours ago, Samrae said:

As recommended elsewhere, please put macro samples in a codebox (see <> above) instead of posting an image.

 

When you have the macro do a Text Type <ALT>E what gets sent to the application is <ALT Down> <Shift Down> e <Shift Up> <ALT up>. What you need is:


Text Type (Simulate Keystrokes): <ALT>e

Sometimes that does not work reliably. This often works better:


Text Type (Simulate Keystrokes): <ALTD>e<ALTU>

 

Samrae - You are right (of course) - just E triggers the export dialog.  So THAT is now fixed. Also the next step to activate the export process works. Then the dialog prompts for a name, and if I manually type CTRL Y, a date appears, but if I let the macro type CTRL Y, nothing happens.  The CTRL-Y is a Macro Express macro which types today's date in the desired format.  I do not mind which method is used, but the next step is to enter today's date in the text box and that is eluding me.

Link to post
Share on other sites
9 hours ago, Sebastian42 said:

if I manually type CTRL Y, a date appears, but if I let the macro type CTRL Y, nothing happens.  The CTRL-Y is a Macro Express macro which types today's date

 

At the point where you want the date-typing macro to run, instead of triggering it with Ctrl-y, use the Macro Run command:

Macro Run: Type_Date

Link to post
Share on other sites

Is my post invisible? 

"The one thing I see that looks wrong is the alternate function for e. I think it shoudl be just e. In Notepad if I want to open "Save As" I type Alt, f, then a. Note that it's not alt+f. and not alt-a. Once the menu is active, you don't use the alt key anymore. That's only in dialog boxes. "

Link to post
Share on other sites
18 minutes ago, Cory said:

Is my post invisible?

Be kind.  He has been told this three times now across two or three threads.  I think he's a newbie trying to get a feel for ME, so best not to scare him away.  When I think of the questions I asked when I started using ME, most people must have assumed I was a total moron.  Happily most of those posts are lost in the mists of history, but I could come up with more at any time. 🤔

  • Like 1
Link to post
Share on other sites

rberq - I'm not exactly a newbie - having used ME for many years - but my increased understanding of its workings in 2020 probably equals or exceeds that up to 2020. As I become more aware of its potential, I'm becoming more ambitious. However, if not a newbie maybe a moron, because I am not aware of being told something three times. Cory - the 'e' issue was solved by Samrai - I have moved in since then. Acantor - I'm about to experiment with y versus Y - If I remember correctly, a date inserted by ME is not in the format I want it - today being 20200821.

I repeat that one or two posts I have made have not appeared in the forum - so my response may seem to have gaps.

 

Using 'y' instead of 'Y' fixed the date insertion issue. Incidentally I used the more secure <CTRLD>y<CTRLU> that Samrai alerted me to.

 

There is of course yet another blockage ! EVERY step is a battle.

 

That blockage was obviated by inserting a delay.

 

ONE step to go !

ALSO fixed by a delay.

The macro now finally runs as desired - many thanks to all the contributors to this success.

 

 

Link to post
Share on other sites
8 hours ago, rberq said:

When I think of the questions I asked when I started using ME, most people must have assumed I was a total moron.  Happily most of those posts are lost in the mists of history, but I could come up with more at any time. 🤔

 

Me too! If we scored it, I reckon that's a challenge I think I might win. 😉

 

Link to post
Share on other sites

I thought my "e" solution was different than Samrae. And this is the point, it's all confused with multiple posts for what is essentially the same goal. I regret spending time offering my thoughts. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...