Jump to content
Macro Express Forums

Recent slowing down of keystrokes and mouse moves?


Recommended Posts

Have any other Win 10 users noticed that keystrokes and mouse moves have become significantly slower since a few days ago?

 

It's most noticeable in my scores of shortkey-activated macros, which type my frequently used filenames and paths, but also with mouse moves. When time allows I'll examine each of them for editing possibilities.

 

I suspect it's just another quirky consequence of the latest Win 10 update.

 

Terry

Win 10 Pro, Version 1909 (OS Build 18363.1016)

Link to comment
Share on other sites

Since "upgrading" to Windows 10 about six months ago, I've been underwhelmed by its lacklustre performance, whether or not I am using macros. Many hotkey and shortkey scripts fail to run the first time, and sometimes the first several times, I activate them. My pixel hunting scripts have become useless, even after I modified them to check every 10 or 100 pixels instead of every pixel. Everything happens in slow motion in Windows 10.

 

The performance of my first computer (an XT clone running MS-DOS, circa 1988) was snappier!

Link to comment
Share on other sites

For what it's worth -- Here are some hints from another forum that I follow.  No warranty expressed or implied.
 

Always remember: "Microsoft is arrogant and will *tell you* what you want" and "Google wants to know and control everything about you, all the time"

To that end, here are some easy tips to speed up Win 10.

1. Ctrl-Shift-Esc for task manager, go to Startup tab. Disable Onedrive.

2. Hit windows key, search for 'background apps'  Turn them all off

3. Open Chrome. Settings, Advanced.
     a. Preload pages- off
     b. Continue running background apps - off

4. If using SSD, turn off SysMain service

5. Install AVG free (if home computer). Disable AVG Secure brower, disable Web Shield, disable cleanup. (MS Defender will move out of the way, it is VERY SLOW)

6. Add Malwarebytes free (if home computer). Like AVG, the paid versions are 'too heavy' and drag down system performance.

Bang, 10-30% increase from just those few things. The difference should be noticeable upon reboot.

Consider upgrading to SSD drive. They are pretty cheap these days.

In task manager you can look at performance tab and see if it is amount of memory, Processor, or disk drive that is the anchor. Memory is easily upgraded, disk drive intermediate (maybe difficult on some laptops) with cloning or reinstall necessary.

 

Link to comment
Share on other sites

I have not noticed anything abnormal but, I don't do mouse moves. I still experience a problem when my computer has been inactive for a spell that the first time I activate a macro, there's a delay in execution. A second or more. But then it's fine. 

I also have a long-standing problem of what I call "molasses" where my machine slows to a crawl and doesn't become responsive again until I kill the MEP process. But apparently it's unique to me. 

Neither of these sound like your problem and my macros are running well. 

Link to comment
Share on other sites

I like Samrae's suggestions that posted while I was typing about disabling anti-virus and security software. Turn off as many things as you can to see if a running app is fighting you. Also try running in safe mode. If it doesn't happen there, it's likely a conflict with one of the running processes. 

Link to comment
Share on other sites

Thanks for the feedback and all suggestions.

 

Cory: Settings confirm my OS is “up to date”. As I’m sure you know, unlike regular application programs, OS versions are not under users control (apart from delaying the next one for a time).The ‘latest’ varies by country and PC spec. So I cannot force MS to update my version to 2004, if that was your implication.

Link to comment
Share on other sites

23 hours ago, Samrae said:

Stupid question: Does it help if you restart Macro Express and/or Windows?

 

My macros slowed waaay down when we switched from Norton Internet Security to BitDefender. (I cannot wait to get rid of BitDefender. 🙁)


Not even rebooting improved it. But I’ve been able to  fix it for many of these macros by using the clipboard paste  option instead of simulating keystrokes.

Link to comment
Share on other sites

Do you have a macro that uses the Keystroke Speed command? I discovered that if one macro sets the Keystroke Speed, to 500 say, and does not reset it back to 0 then all other macros that I run after that type text slowly. I try to remember to set Keystroke Speed back to 0 in any macro that changes it.

 

You could check for this by putting a Keystroke Speed: 0 at the top of one of your macros that is typing slowly. If it starts to work more quickly you can search for the macro that slows down the keystroke speed.

 

Another thing to check is whether the Delay after keystroke value found in Playback, Delays has been changed. The default value for this is 300.

Link to comment
Share on other sites

Click here. 2004 was available as of 5/27, 99 days ago. Perhaps you have security software that's causing your Windows Update to fail.

2004 was an optional install for me, not a critical update done automatically. I think later it was forced. But I'm not sure. 

Also don't trust it when it says "You're up to date."  and "Last checked" a couple days ago. Many times I've clicked "Check for Update" and 'et voila' now magically it finds one or more that have been available for over a week. I check manually all of my machines this way once a week and I frequently find updates this way. In fact, that's why I do it. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...