Jump to content
Macro Express Forums

MEX Pro 4 running macros via shell

Recommended Posts

Hey everyone,


I kinda noticed an odd behaviour between Win7 and Win10 when trying to run Macros via shell commands.


I have some Macros that get executed via Nuance Dragon 15 voice recognition. The Script is as follows:


ShellExecute "C:\Program Files (x86)\Macro Express Pro\MeProc.exe /APosteingang"


Which is equivalent to a .bat file containing:


start C:\Program Files (x86)\Macro Express Pro\MeProc.exe /APosteingang


Now to the Problem.

When I run this on Win7 everything works as expected and the Macro "Posteingang" executes.

But when I run this on a Win10 machine a blank CMD-like window of "MeProc.exe" with the MEX Icon opens for a split second and closes itself (see image below), the Macro doesn't get executed.

I tried several other things in a .bat file like:


start "C:\Program Files (x86)\Macro Express Pro\MeProc.exe" /APosteingang


adding the " or ' in different positions, without success. 

I don't understand why it behaves differently and what would need to be changed to make it work on Win10 machines. Any ideas?



Link to comment
Share on other sites

In the .bat file, put a PAUSE command at the end, for testing.  That should keep the window from closing, so you can see error messages.  


Or try sending the output to a text file that you can examine:

start "C:\Program Files (x86)\Macro Express Pro\MeProc.exe" /APosteingang  > c:\temp\temp.txt

Link to comment
Share on other sites

I could not get a batch file containing any of these to work:

start C:\Program Files (x86)\Macro Express Pro\MeProc.exe /APosteingang

start "C:\Program Files (x86)\Macro Express Pro\MeProc.exe /APosteingang"

start "C:\Program Files (x86)\Macro Express Pro\MeProc.exe" /APosteingang


But a batch file containing this worked on both Windows 7 and Windows 10:

"C:\Program Files (x86)\Macro Express Pro\MeProc.exe" /APosteingang


I expect the parameter in Dragon should look like this but I do not have Dragon to try it:

ShellExecute "C:\Program Files (x86)\Macro Express Pro\MeProc.exe" /APosteingang


Have you considered upgrading to Macro Express Pro 6? Maybe it contains a change that would help.

Link to comment
Share on other sites

  • 2 weeks later...

This is one way it worked for me (i got MEP


Syntax: start /D [Path from Macro Express] MeProc.exe /A::[Path where the macro is stored]?[Macroname]


For Example:

start /D "C:\Program Files\Macro Express Pro\" MeProc.exe /A::C:\Dokumente\Insight Software\macex.mex?Posteingang


That's a lot of code, but it works 😉

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...