Jump to content
Macro Express Forums

Incorporating imported macros


Recommended Posts

In a thread called DISABLEMENT, I described how MEP had stopped working and that it works again. Since I had uninstalled and then re-installed MEP, I needed to 'restore' the macros, and chose to restore only the text-strings (for starters). I'm no longer quite sure how I did it. I tested them and they work. Anyway, with MEP working again, I also wanted to restore the 'function' macros. I had expected to be able to export them 'in bulk' from another PC,  but did not succeed in that. so I exported them individually. Then imported them - individually - into 'this' system where the problem had been. The batch files in which they were referenced, do not work [like they used to].

 

In the previous thread, Cory suggested that the macros had not been loaded, and maybe that is the problem now. I suspect that MEP is working from one .mex file (for all the text strings) and that file does not include the .mex files for the 'function' macros. How do I get them incorporated into the one file that MEP operates from ?

 

 

Link to comment
Share on other sites

See screen image below.  The file that MEP is working from should appear at the bottom of the screen, where the red arrow is pointing. 

 

You can copy the entire .mex file from the 'old' computer, and put it on the new computer -- just be sure to name it differently from the file that MEP is working from.  Then in Macro Explorer, select File | Import | Import Macros, specify the copied .mex file at the bottom of the import screen, click Open, then select the individual macros to be imported. 

 

ScreenCapture_7_8_2021_15_06_04.jpg

Link to comment
Share on other sites

I've tried explaining this. Macros are entities contained in an MEX file. You need that MEX file to be loaded. File > Open. Then they will appear on the left.

Bear in mind you might have multiple files open at once so make sure when you create anew macro you are choosing the correct file to contain it.

Just like Word, Excel, or whatever, you shoudl be mindful of which MEX files contain your macro and where they are. It's been a long time but I believe the default was a folder created by thin installed in your My Documents named "Insight Software\Macro Express 6". It's best you keep your macros in one place along with all your supporting files. 

Link to comment
Share on other sites

You could also search your My Documents or whole hard drive for all files with the MEX extension. The newest should be the one you were using. 

Link to comment
Share on other sites

The problem turns out to be my misrepresentation of the facts, because I misunderstood what was happening. I had imported two macros, and tested only one. It failed and I assumed both failed. The failure was because I had taken the opportunity to rename the macro more appropriately, but not made that change in the batch file that calls the macro. Once I had done that, it worked. Another (that I had not tested) would have worked all along.

 

MEP works as before - thank you for your input.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...