Jump to content
Macro Express Forums

Ex 3 locking up in Win10


Recommended Posts

Hi all, I have used Ex 3 for many years and have it set up for opening programs and working with hot keys to select simple tasks, nothing elaborate.

Just installed for the first time on an HP Pavilion DV7 laptop with a fresh install of Win10 20H2 and am finding certain features ei1ther do not work or halfway though a task it just stops and will not go the the next line. Other simple tasks work fine that have maybe 5 lines but is one with 15 lines seems to stop at the same point each time when I activate it, they have always worked fine for many years on my XP computers. Question: Is this a compatibility issue or do I need a patch or something. Any help would be appreciated.

Many thanks...

Link to comment
Share on other sites

What version of MacroExpress 3 do you have?  I believe the last version I used was 3.7.3, though I think there are later updates, like maybe 3.11. 


Some hotkey combinations that worked in older Windows versions, are now reserved by Windows, so the macro does not get initiated.


Can you post an example of a short macro that fails and indicate where it is failing?

Link to comment
Share on other sites

By my count, line 51 is the one highlighted in blue in this screen image. 

Sorry, I can't see any reason the macro would stop at that point.  I notice that a few lines before 51, there is a 100 second delay (red arrow).  One minute and forty seconds.  That's a pretty long time if you are sitting waiting for the computer to do something.  Are you sure that is not where it stops -- or appears to stop?



Link to comment
Share on other sites

The 100s is to allow a program to register and load files. The next line minimizes the window then the rest are commands that just open a series of smaller programs.

I cannot find a reason why it hangs at that point. I will have to keep on playing with it.

Thank you for your time...

Link to comment
Share on other sites

I'm going out on a limb here and going to suggest that the macro program doesn't want more than 50 lines.


I'm going to split the macro into two macros and the last line will start the second macro.


Could you please point me to the command line that will start a second macro.


Many thanks for your help....

Link to comment
Share on other sites

I have very few macros that are less than 50 lines.  However, splitting yours into two macros will be a learning experience.😐

The "Macro Run" command starts another macro.  It's in the Macro Control group of commands. 


One more thing you could look at -- is it possible that the target of your Mouse Move is in a slightly different screen location than it was on the old PC and old Windows version?  So the macro could be clicking at the wrong place?  Use the Mouse Locator tool to manually check on that.  

Link to comment
Share on other sites

The whole kerfuffle on my part was fixed by running my older programs and express3 in XP compatibility modes.

Totally cleared up most of my problems and am left with one that I can't seem to figure out. MacroExpress3 in Start up menu I have

checked the lower three boxes which I have checked for years with this program and it will not start on windows start up.

Starting my windows 10 I have to manually start the program, does anyone have any suggestions.

Many thanks again....

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...