Jump to content
Macro Express Forums

Mouse Wheel Scoll Doesn't Work In Firefox And Ie?


Magic
 Share

Recommended Posts

Hi there,

 

I'm new to ME and for now (still haven't received my registration key :blink: ) I'm working with the trial version of the latest ME.

 

Love the program, my girlfriend has RSI and this is a real solution for her!

(although I have to configure the macros ;))

 

I'm having one problem though:

 

I can't get the mouse wheel scroll to work in Firefox (my default browser) and/or IE.

It works in other programs (Tag&rename and Newsleecher are no problem) but in FF and IE it's a no go.

 

Is this a bug or do I something wrong?

The mouse is a Logitech MX700 (cordless with the latest mousware)

Link to comment
Share on other sites

It worked for me.

 

At first it didn't look like it did, because I expected "Forward" to scroll down the page, and instead it scrolls up- so if I was already at the top of the page, nothing happened. Might this be the issue?

 

I just used a simple one-line macro, that invoked ten clicks on the mouse-wheel and did nothing else.

Link to comment
Share on other sites

I have a logitec optical mouse with a mousewheel, but if I understand correctly, that shouldn't make a difference to ME, since the signal isn't actually coming from the mouse (the scroll-wheel command, for example, should work even if your mouse doesn't have a scrollwheel. Agian, IIUC.)

 

Perhaps if you posted the source code, someone might be able to figure out why it isn't working?

 

Try using the test macro I used- just one line, "Mouse Wheel Forward", set to ten clicks, and a command-key invocation. Wether that one-line macro works or not should help narrow down the source of the problem. (Remember, this will cause it to scroll UP, so start at the botom of a page)

Link to comment
Share on other sites

I also have a logitech optical, but mine is cordless maybe that's the problem?

 

Small update: you're one line macro does actually work!

 

Next question is why doesn't it run in a macro which opens firefox first, starts up a website and then has to scroll....... :blink:

 

Small update 2: This is strange, with the following lines:

mouse move screen: xx,yy

mouse wheel 3 clicks backward

 

it does scroll, no problem at all!

 

but with the exta line:

Web site: http://whateverwebsiteIchoose

mouse move screen: xx,yy

mouse wheel 3 clicks backward

 

it doesn't work anymore!

:o how about that.........

Link to comment
Share on other sites

Linda I emailed insight with this problem and I got an email from Stan.

 

He said that a webpage has to be fully loaded before a scroll can work, so he advised to use a delay or wait command before the scroll command

 

I did and it worked! B)

 

Thank you for looking into this problem! really appreciated it! :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...